Drupal URLs werken niet

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Koen Vlaswinkel

Koen Vlaswinkel

15/09/2013 16:33:24
Quote Anchor link
Ik gebruik Drupal 7, Apache 2.4.7 en PHP 5.5.3. Ik heb ze recentelijk geüpdatet, maar ik denk dat mijn probleem hier niet aan ligt.

Als ik mijn hoofdpagina open, laten we even http://example.com zeggen, krijg ik een 404 van Drupal. Ditzelfde als ik http://example.com/user/login opvraag, wat betekent dat mod_rewrite wel werkt.

Echter, als ik http://example.com/?q open, dan doet hij het wel. Ik vind het dus erg gek dat het wel werkt als ik een lege q toevoeg. Als ik geen toevoeg is $_GET['q'] wel gewoon NULL, dus dat zou ook niet het probleem moeten zijn.

Het raarste vind ik nog de URL op de Not Found pagina:
The requested page "/http://example.com/" could not be found.

Waarom staat er een slash voor de http://example.com en wordt http://example.com überhaupt vernoemd? Ik heb volgensmij alles hier al gevolgd, en dit verhelpt het niet. Ik heb Clean URLs trouwens niet aanstaan.
 
PHP hulp

PHP hulp

01/03/2024 05:03:51
 
Koen Vlaswinkel

Koen Vlaswinkel

16/09/2013 22:11:10
Quote Anchor link
* bump *

Niemand een idee?
 
Ward van der Put
Moderator

Ward van der Put

17/09/2013 07:40:44
Quote Anchor link
Het lijkt op een fout in een rewrite rule, waarbij ?q=... een afwijkende routing heeft voor zoekopdrachten dan /http://example.com/ met extra slash.
 
Kris Peeters

Kris Peeters

17/09/2013 10:19:19
Quote Anchor link
Kan je de clean url's uit zetten?
Dus inderdaad,alles met ?q=...
 
Koen Vlaswinkel

Koen Vlaswinkel

17/09/2013 14:02:20
Quote Anchor link
Ik begin langzaam aan het gevoel te krijgen dat het aan Chrome of aan het feit dat ik mijn HOSTS file gebruikte ligt. Als ik op een andere laptop in Firefox een proxy instel die ik zelf heb gehost, die via zijn /etc/hosts naar mijn site wijst, werkt het wel. Als ik mijn rule weghaal uit mijn HOSTS, dan doet Chrome het nog steeds niet, maar Firefox wel. Ik heb nu dus voor één van mijn domeinen die naar die website point de DNS aangepast en als ik dan een website speed test doe om te kijken hoe mijn website eruit ziet op http://tools.pingdom.com/, krijgt die ook geen error.

Ik zal dus even afwachten tot de DNS instellingen zijn doorgevoerd, maar het lijkt erop dat het ligt aan Chrome.

Ik was nog even aan het testen, maar het ligt dus aan een extensie in Chrome die ik gebruikte. Ik weet nu tenminste wel dat ik Hosts Manager niet ga aanraden! Alles lag aan deze extensie, voor de rest doet mijn website het dus gewoon.
 
Kumkwat Trender

Kumkwat Trender

17/09/2013 19:39:04
Quote Anchor link
hoe ziet je .htaccess file eruit?
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.