Ervaren php-er gevraagd voor ombouw site

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Ervaren senior C# developer in Arnhem gezocht

Organisatie Voor een van mijn businesspartners uit de omgeving van Arnhem ben ik op zoek naar een ervaren senior C# ASP.NET developer. Deze organisatie maakt complexe software producten voor bepaalde bedrijfsprocessen. Denk hierbij aan beslisregelsystemen, klachtenmanagementsystemen, digitale formulieren of een combinatie hiervan in één portaal. De software wordt specifiek op elke klant zijn wens aangepast. Bij de klanten moet je denken aan enerzijds provincies, gemeenten en overheidsinstanties en anderzijds aan banken, hypotheekverstrekkers en verzekeringsmaatschappijen. Binnen het bedrijf, van circa zestig man groot, heerst een informele sfeer. Collegialiteit staat er hoog in het vaandel, wat je terugziet in de wekelijkse vrijdagmiddagborrel

Bekijk vacature »

Als PHP programmeur werken aan IT oplossingen voor

Vacature Omschrijving Deze fraaie partij ondersteunt bedrijven bij hun technische vraagstukken door middel van software, trainingen, de inzet van specialisten en state of the art apparatuur. Hun missie is: “Het leveren van technische producten, diensten en systemen die van meerwaarde zijn voor de opdrachtgevers.” Zij beantwoorden dan ook de meest uiteenlopende technische vraagstukken, waarbij zij zich richten op vijf marktsegmenten: Bovengrondse Infrastructuur, Ondergrondse Infrastructuur, Bouw & Installatietechniek, Geo & Data en Industrie & Energie. Als technisch specialist ontwerpen zij niet alleen producten en oplossingen voor deze marktsegmenten, maar nemen zij ook het beheer en onderhoud op zich. Deze groeiende partij

Bekijk vacature »

Peter Arendse

Peter Arendse

04/03/2019 20:50:20
Quote Anchor link
Lieve mensen,

Vele jaren geleden heb ik met hulp van jullie, en wat knip en plakwerk een goed werkend script in elkaar gedraaid dat tot op vandaag stabiel werkt, werkte....totdat mijn provider de php versie verhoogde tot 7.
Het script werkt prima onder versie 5, daarboven krijg ik foutmeldingen met het aanroepen van de mysql database.
Waarschijnlijk gaat het om de omschakeling naar mysqli en de overige functies die er bij horen, tevens zal de beveiliging out dated zijn.
Zelf kan ik het niet meer omdat ik ruim drie jaar geleden een herseninfarct heb gehad en concentreren of iets nieuws leren te veel van mijn energie kost, energie die ik hard nodig heb om mijn eenmanszaak en mijn gezin draaiende houden.
Het zijn 15 kleine pagina's waarin een aantal codes veranderd moeten worden of aangepast.

Ik werk met 4 (taxi)collega's samen en die bouwen al meer dan 10 jaar helemaal op mijn script waarbij reserveringen in een database stoppen, opvragen, aanpassen etc.
Het niet meer zelf kunnen updaten van het script is qua acceptatie voor mij al moeilijk genoeg, vandaar dat ik nu hulp zoek bij jullie.
Het hoeft niet gratis, wel heb ik een beperkt budget.

Met veel belangstelling zie ik de reacties tegemoet,
Met vriendelijk groet,

Peter Arendse
Zaandam
Gewijzigd op 05/03/2019 18:46:52 door - Ariën -
 
PHP hulp

PHP hulp

18/07/2019 01:26:34
 
- Ariën -
Beheerder

- Ariën -

04/03/2019 21:17:13
Quote Anchor link
Aan welk budget dacht je?
 
Peter Arendse

Peter Arendse

05/03/2019 05:36:51
Quote Anchor link
Beste Arien,

Fijn dat je zo snel kon reageren, we zijn met zijn vieren die toegang hebben tot de database dus ik dacht aan max. €400,00.
Mijn nieuwe website die ik heb laten maken in Wordpress vraagt ook om php 7, vandaar mijn vraag op het forum.
Ik verwacht dat een ervaren programeur zich de scheuren in zijn broek zal lachen om mijn script, maar voor ons werkt het en dat is het belangrijkste.
Qua veiligheid vind ik het ook belangrijk dat het weer up to date moet zijn, onze klanten verwachten natuurlijk dat hun gegevens die ze aanleveren met zorg worden beschermt.

Graag hoor ik of je iemand weet die wat kan betekenen voor ons,

Met vriendelijke groeten,

Peter Arendse
 
Ozzie PHP

Ozzie PHP

05/03/2019 11:03:13
Quote Anchor link
Aangezien je aangeeft dat het een WordPress site betreft, is het dan niet slimmer om een compleet nieuwe site op te zetten? Met nieuwe PHP-versie en nieuwe WordPress installatie?

Als je er commercieel van afhankelijk bent (ik begrijp dat het een taxibedrijf betreft) dan zou ik zeker investeren in een goede en veilige site. Je wil niet dat de gegevens van je klanten op straat komen te liggen. Mijn persoonlijke advies zou zijn om met z'n vieren wat meer geld uit te trekken en een degelijke site te laten maken bij een internetbureau. Als het goed is, verdient het zichzelf weer terug.
 
Bart V B

Bart V B

05/03/2019 11:37:25
Quote Anchor link
Eens met Ozzi, ook daar kan je geld besparen als het om Wordpress gaat.
Het probleem is meestal het grafisch schilletje dat er omheen gemaakt moet worden gemaakt.
Wordpress installeren is meestal niet zo heel spannend en is makkelijk zelf te doen.
Als je een custom thema wilt laten ontwerpen en deze zelf daarna installeert dan ben je er toch al?

Wat ik mij alleen afvraag, Wordpress eenmaal geïnstalleerd kan je toch gewoon updaten?
Dus waarom helemaal opnieuw beginnen?

Ander verhaal word het als je bestaande wordpress eigen gemaakte plugins bevat.
Dat probleem zou je nog kunnen tackelen door te kijken of er een bestaande plugin is die zo ongeveer het zelfde doet.
 
Peter Arendse

Peter Arendse

05/03/2019 13:06:27
Quote Anchor link
Heren, heren,

Om gelijk een misverstaand uit de wereld te halen, het gaat niet om een Wordpress website maar om een eigen script.
Waarschijnlijk heb ik het verkeerd gebracht in mijn aanvraag ( zo werken blijkbaar mijn hersenen tegenwoordig).
Vroeger maakte ik mijn eigen website maar heb onlangs een website laten maken en deze is van Wordpress.
Om Wordpress goed te laten werken was het nodig om php 7 in te schakelen bij mijn provider, toen kwam ik er achter dat mijn eigen script ( een soort agenda ) dramatisch verouderd was en dat ik die moet opwaarderen zodat deze ook weer voor jaren werkt volgens de huidige normen en veiligheideisen.
Ik had dus de keuze, of ik laat php 4.6 draaien en mijn agenda werkt en de nieuwe website maar half(volgens het bedrijf wat de site gemaakt heeft), of ik schakel over op php 7 en mijn agenda script werkt niet meer en de nieuwe website wel!

Er bestaat software voor taxicentrales, die werken via datacommunicatie en hebben de mogelijk om factureringsprogrammas aan te koppelen maar dat is voor ons totaal niet nodig en niet te betalen, vandaar mijn eigen kindje waar ik best wel trots op ben, maar net als ikzelf een beperking heeft opgelopen sinds de jaren vorderen, hahaha!
Ik heb voor het laatste gekozen en dus vraag ik hulp met het updaten van mijn agenda script!
Gewijzigd op 05/03/2019 13:13:44 door Peter Arendse
 
Ozzie PHP

Ozzie PHP

05/03/2019 13:15:55
Quote Anchor link
En die eigen agenda moet geïntegreerd worden in de nieuwe website? Of staat dat los van elkaar?
 
Peter Arendse

Peter Arendse

05/03/2019 13:26:25
Quote Anchor link
Hoi Ozzie,

Deze staat totaal los van elkaar, draait alleen in de zelfde webspace als de website, vandaar mijn probleem.
Verder vind ik het belangrijk dat ook qua veiligheid het script afgeschemt wordt, we zijn wel in het bezit van een aantal prive gegevens van onze klanten.
Het script maakt gebruik van een mysql database met ik geloof maar 5 tabellen.
Het aanroepen en comuniceren met de database vraagt tegenwoordig om mysqli, waar volgens mij ook twee versies van zijn of een systeem wat kan communiceren met meerdere soorten databases ( het duizeld me nu al als ik er aan denk)
 
- Ariën -
Beheerder

- Ariën -

05/03/2019 18:45:52
Quote Anchor link
Terug gaan naar PHP 4.6 (die niet eens bestaat, of PHP 4) is geen optie. Die is al zwaar bejaard... ;-)
Mocht iemand zich willen aanbieden om het op te knappen, dan kan die zich hier melden. Ik zal het meteen ook even naar het Vacatureforum gooien.
 
Thomas van den Heuvel

Thomas van den Heuvel

06/03/2019 01:07:23
Quote Anchor link
@Peter persoonlijke berichten al gecontroleerd? Zie linksboven op de pagina.

http://fangorn.thijma.nl/images/phphulp/persoonlijk-bericht.png

Misschien aandachtspuntje om dat ding er eens wat meer uit te laten springen?
 
- Ariën -
Beheerder

- Ariën -

06/03/2019 01:09:52
Quote Anchor link
Als het goed is komt er ook een gratis mail bij.
 
Furio Scripting

Furio Scripting

13/03/2019 20:50:10
Quote Anchor link
Beste topic starter,

Ik kan je hier wel mee helpen vermoed ik mocht je nog hulp nodig hebben. Kan ik eens naar het script kijken en zien of het te doen is voor €400.

Bij interesse graag een prive berichtje of reageer hier :-)

Mvg Furio
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.