functie eregi vervallen

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Pagina: « vorige 1 2 3 4 5 volgende »

- Ariën -
Beheerder

- Ariën -

10/02/2019 16:01:49
Quote Anchor link
Het zou kunnen, maar met lijkt me met oude code uit 2003 zéér tijdrovend. Plus dat je gevoelig kan zijn voor veiligheidslekken. Denk aan spam, phishingpagina's uitgelekte klantgegevens (die je in dat geval bij de ACM dient aan te geven) etc....

Ikzelf raad aan om oude software te verwijderen of te vervangen. Wat nu nog nog niet lijkt te zijn gebeurd aan hackpogingen, kan altijd gebeuren als je je er niet tegen wapent.
Gewijzigd op 10/02/2019 16:20:46 door - Ariën -
 
PHP hulp

PHP hulp

17/08/2019 13:42:07
 
Jan douma

jan douma

10/02/2019 16:21:52
Quote Anchor link
Ja, wil er eigenlijk zo weinig mogelijk tijd aan besteden aan die oude shop.
Zat weleens te denken aan een Wordpress shop, maar misschien met een recente versie van Oscommerce ?
Al met al ..een heel gedoe allemaal iets opnieuw gaan maken en op de nieuwe shop is er ook geen echte verkoop meer te verwachten.

Een easy fixes voor die oude code uit 2003 zit er ook niet in he.
 
- Ariën -
Beheerder

- Ariën -

10/02/2019 16:25:13
Quote Anchor link
Of maak er statische HTML van omdat de shop toch niet meer actief is als shop.
Met Httrack kan dat bijvoorbeeld.
Gewijzigd op 10/02/2019 16:29:14 door - Ariën -
 
Jan douma

jan douma

10/02/2019 16:29:11
Quote Anchor link
Word ook lastig om oude oscommerce software over te zetten naar de nieuwste oscommerce die object georienteerd is geprogrammeerd ..weet ook niet meer de weg te vinden in de nieuwste versies denk ik.
 
- Ariën -
Beheerder

- Ariën -

10/02/2019 16:31:02
Quote Anchor link
Of statisch maken zoals ik zei, maar weeg het eens af of het nog nuttig is om de inhoud te archiveren. Wordt de inactieve shop nog bekeken door anderen?
 
Jan douma

jan douma

10/02/2019 16:34:54
Quote Anchor link
Bedankt voor het idee!, misschien een statische HTMl website..er is eigenlijk geen andere gemakkelijke alternatief.

Toevoeging op 10/02/2019 16:36:08:

Ja er zijn mensen die er nog wel op kijken naar produkten om een idee te krijgen

Toevoeging op 10/02/2019 16:40:50:

Deels kan de site mogelijk nog informatief zijn voor een klant

Toevoeging op 10/02/2019 16:44:12:

Vandaar ook de moeite om het te laten draaien.. de shop

Toevoeging op 10/02/2019 16:46:05:

Als het echt niet meer lukt om de shop draaiende te houden, dan moet het ophouden ..het bestaan ervan

Toevoeging op 10/02/2019 17:11:47:

Bedankt voor je hulp!
 
Ivo P

Ivo P

11/02/2019 16:14:15
Quote Anchor link
Jan douma op 10/02/2019 13:42:52:
Op mijn website server is een nieuwe php versie 5.3 draaiend, maar krijg nu foutmeldingen en de website functioneert niet meer


De combinatie "nieuw" en "5.3" in 1 zin is wat raar.

Versie 5.3 is al End of Life sinds augustus 2014. Versie 5.2 al sinds januari 2011. JE hoster is dus eigenlijk al diep een museum in moeten duiken voor deze versie.
http://php.net/eol.php

Kun je dus nagaan hoe oud jouw code is als je kennelijk PHP 5.2 of ouder nodig hebt.

https://museum.php.net/

Ik zou voor een nieuwe site gaan. Misschien statische html, of misschien wel iets gebaseerd op Wordpress of iets dergelijks. Al moet je dat ook regelmatig updaten.
Wil je er geen omkijken naar hebben, is statische html misschien wel het simpelste
 
Jan douma

jan douma

11/02/2019 19:42:28
Quote Anchor link
Mijn webhost heeft de shop tijdelijk op een server gezet waarbij je de PHP server versie kunt instellen ( nieuw voor mij) vanaf 5.3 tot de nieuwste 7..
Voor mij was de versie 5.3 "nieuw" omdat de shop altijd op een oudere versie PHP gedraaid heeft



Toevoeging op 11/02/2019 19:46:10:

Had de shop graag willen laten doordraaien zoals het al vanaf 2003 gebeurde
De shop functie is alleen maar informatief geworden..verkoop was stilgezet.

Toevoeging op 11/02/2019 19:54:29:

http://zerospec.com/.. wat er van over is veroorzaakt door de nieuwe 5.3 server php.
Heb ook wel eens een wordpress website gemaakt, maar de oude feel van de oude shop is weg
 
- Ariën -
Beheerder

- Ariën -

11/02/2019 19:54:59
Quote Anchor link
Je hosting zal in ieder geval versie 5.3 niet oneindig lang blijven ondersteunen, en het is hoogstwaarschijnlijk puur bedoeld zodat je site site kan fixxen. Maar gezien de oudheid zou ik het gebruik van dat softwarepakket gewoon afraden, tenzij je uren wil patchen en updaten.
Gewijzigd op 11/02/2019 19:55:36 door - Ariën -
 
Jan douma

jan douma

11/02/2019 21:22:23
 
- Ariën -
Beheerder

- Ariën -

11/02/2019 21:27:45
Quote Anchor link
Van die link...
Quote:
At this point what you effectively have is your own "fork" of osC, that you are responsible for maintaining. Over time, there will be less and less support available here, simply because no one will be using osC 2.2 any more.

Je bent dan zelf verantwoordelijk voor het onderhoud en het updaten. Is dat de moeite waard voor iets dat je niet meer actief gebruikt? Eigenlijk heb je wel mazzel dat je niet gehacked bent/lijkt te zijn.
 
Jan douma

jan douma

11/02/2019 21:50:15
Quote Anchor link
Ja, dat is nog nooit voorgekomen en wat is tegenwoordig hackvrij van de webshops ?
 
- Ariën -
Beheerder

- Ariën -

11/02/2019 22:16:38
Quote Anchor link
Daar kan je weinig over zeggen, er duiken altijd wel eens lekken op. Het belangrijkste is dat je de boel up-to-date houdt. Zowel je webshop, als de plug-ins en de severconfiguratie.
Gewijzigd op 11/02/2019 22:16:53 door - Ariën -
 
Jan douma

jan douma

12/02/2019 09:09:52
Quote Anchor link
Geweldig,de shop doet het weer http://zerospec.com/
Nog 1 foutmelding te zien : Deprecated: Function session_is_registered() is deprecated in /home/jdouma/domains/zerospec.com/public_html/admin/includes/functions/sessions.php on line 74
 
- Ariën -
Beheerder

- Ariën -

12/02/2019 09:14:48
Quote Anchor link
- Ariën - op 10/02/2019 15:23:17:
Met isset() kijken of $_SESSION['sessienaam'] bestaat.


Knap dat je een oud script weer gepatched hebt zodat deze op nieuwere PHP-versies draait. Maar dit doet nog niks aan de veiligheid. Misschien is het sowieso een idee, omdat het niet actief is, om persoonlijke data uit de database te halen.
Gewijzigd op 12/02/2019 09:18:13 door - Ariën -
 
Jan douma

jan douma

12/02/2019 09:24:36
Quote Anchor link
Is geen verdienste van mij, maar van mijn webhost :)
De webshop heb ik toen gemaakt met hulp van het nederlandse osc forum en natuurlijk heb ik wel een beetje kijk op programmering, maar dan houdt het ook op.
Heb nog weleens overwogen om dieper de php programering te leren, maar dat vereiste zon studie
Kon ook nooit achterhalen hoe de shopping kaart programmering precies werkte, waarom dit en dat
Is wel leuk om te doen, maar wel ingewikkeld.





Toevoeging op 12/02/2019 09:35:17:

Van de klantis er alleen een eerste naam, achternaam, e-mailadres, straat, postcode , stad en land + telefoonnummer bekend.
Wat moet iemand hiermee?


Toevoeging op 12/02/2019 09:36:36:

Weet niet of de database gemakkelijk gehackt kan worden
 
- Ariën -
Beheerder

- Ariën -

12/02/2019 10:02:07
Quote Anchor link
Jan douma op 12/02/2019 09:24:36:
Van de klant is er alleen een eerste naam, achternaam, e-mailadres, straat, postcode , stad en land + telefoonnummer bekend.
Wat moet iemand hiermee?

Handelen voor spam?
Quote:
Weet niet of de database gemakkelijk gehackt kan worden

Haal persoonlijke gegevens eruit.
"Better safe than sorry"
Gewijzigd op 12/02/2019 10:08:53 door - Ariën -
 
Jan douma

jan douma

12/02/2019 15:26:52
Quote Anchor link
Dit maakte ik dan vroeger voor de shop ..http://www.zerospec.com/infoextra_carbonmirrorkappen_wrx.php
Is toch leuk voor een klant?
Heb nog een database probleem : de produktzoeker doet het ook niet meer ( blijft zoeken..voorbeeld http://www.zerospec.com/limited-slip-differential-c-1338_1944_1949.html en de produkteditor werkt ook niet meer onder windows 10
Misschien is er een oplossing op dit forum te vinden en ook nog d epaar foutmeldingen
Handiger misschien om op xampp te zetten de shop?


Toevoeging op 12/02/2019 15:27:28:

http://www.zerospec.com/infoextra_carbonmirrorkappen_wrx.php
 
- Ariën -
Beheerder

- Ariën -

12/02/2019 15:48:48
Quote Anchor link
Hoezo wou je XAMPP gebruiken?
 
Jan douma

jan douma

12/02/2019 15:58:27
Quote Anchor link
Ja, is eigenlijk ook niet nodig, want er is een backup gemaakt van de shop
Zo deed ik het vroeger ook met de contributies en codeaanpassingen, meteen te zien op de server


Toevoeging op 12/02/2019 16:02:37:

Hoe de produktzoeker (is geprogrammeerd in de Ukraine, maar het bedrijf bestaat niet meer volgens mij?) en html produkteditor ( is een oude oscommerce contributie) weer werkend te krijgen?
 

Pagina: « vorige 1 2 3 4 5 volgende »



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.