.htaccess werkt niet (mod_rewrite)

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

The Hosh

The Hosh

27/12/2006 22:58:00
Quote Anchor link
naar aanleiding van deze tutorial: http://www.phphulp.nl/php/tutorials/8/146/ heb ik dit in me htaccess:
RewriteEngine On
RewriteRule ^forums/ forum.php

maar als ik naar forum.php ga doet die het niet, als ik naar /forums/ gaat doettie ook niet :s
ik krijg een server error (500)

wat is er mis mee?

alvast bedankt
 
PHP hulp

PHP hulp

28/01/2021 17:15:21
 
Crispijn -

Crispijn -

28/12/2006 00:24:00
Quote Anchor link
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^forum forum.php
</IfModule>

Wanneer je forum.php in een andere map staat moet je natuurlijk hier naar verwijzen. Bijvoorbeeld:

RewriteRule ^forum forum/index.php

LET OP! Ik heb het nu zo dat je geen / aan het eind van je url hebt. Dit vind ik persoonlijk mooier en mensen vergeten het minder snel.

Succes
 

28/12/2006 01:05:00
Quote Anchor link
IIS server? Die kennen geen .htaccess
Correctie: er is een module beschikbaar voor directory beveiliging
Mod rewrite kan via ISAPI ReWrite
 
The Hosh

The Hosh

28/12/2006 10:04:00
Quote Anchor link
@Crispijn
het zit zo:
ik heb root folder:
daarin heb ik site
in site heb ik .htaccess en forum.php
en jou stukje werkt ook niet.
kan het liggen aan andere stukje die ik in htaccess heb?
dit is de volledige:
Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
7
8
AuthType Basic
AuthName "Stroef V2"
AuthUserfile "../htdocs/site/.htpasswd"
Require valid-user
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^forums forum.php
</IfModule>


@Webmakerij
geen IIS, ik heb Apache

greeetz
 
The Hosh

The Hosh

29/12/2006 11:19:00
Quote Anchor link
niemand meer?
 
Willem vp

Willem vp

29/12/2006 12:12:00
Quote Anchor link
Uit je eerste mail begrijp ik dat het "ook niet werkt" als je rechtstreeks (dus zonder mod_rewrite) naar forum.php gaat.

Het lijkt me dat je dat probleem eerst moet oplossen voor je iets nuttigs met mod_rewrite kunt doen.
 
The Hosh

The Hosh

29/12/2006 14:58:00
Quote Anchor link
nej als ik dat stukje van mod_rewrite erin zet dan werkt forum.php en /forums/ niet maar als ik dat stukje van mod_rewrite weghaal werkt forum.php gewoon
 
Willem vp

Willem vp

31/12/2006 14:10:00
Quote Anchor link
Daarnet heb ik even je rewriterule getest, en de code zoals jij die hebt gegeven werkt hier perfect.

Het enige wat ik me nog kan voorstellen is dat er een probleem is met je installatie of configuratie van Apache. Staat er nog iets zinnigs in je errorlog?
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.