Na update van php 5.2.13 naar 5.2.14 problemen,,,

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Comanti Com

Comanti Com

25/07/2010 14:24:22
Quote Anchor link
Ik heb een servertje (vps) draaien en zag dat php een nieuwe versie heeft vrijgegeven in de 5.2.x range.
Ik draaide 5.2.13 en wilde dus naar 5.2.14 en toen begon er een probleem te ontstaan.

Misschien goed om te melden dat ik een directadmin panel heb...

Ik was via root aangemeld en heb ingevoerd:
./build update

vervolgens gedaan:
./build php n

Hierna kwamen de problemen, sites op deze server met joomla geven een wit scherm, sites met phpbb de melding:
phpBB Debug] PHP Notice: in file /includes/session.php on line 496: preg_match() [function.preg-match]: Internal pcre_fullinfo() error -3
En: Warning: Cannot modify header information

Verder is vanuit directadmin de phpmyadmin ook niet te benaderen deze geeft een soort gelijke foutmelding:
Warning: preg_match_all() [function.preg-match-all]: Internal pcre_fullinfo() error -3 in /var/www/html/phpMyAdmin-3.3.4-all-languages/libraries/Message.class.php on line 633

Via google ben ik wel wat sites tegen gekomen maar die hebben het vooral over het aanpassen van de header in de php files zelf, maar dat lijkt me niet de juiste oplossing....

Voor de goede orde, zowel joomla en phpBB zijn de meest recente versies en dus up-to-date,..

Het geheel draait op CentOS 5.x en Apache 2.0.63 Server

Weet hier iemand misschien nog wat ik kan doen?
 
PHP hulp

PHP hulp

21/10/2020 13:00:08
 
P Lekensteyn

P Lekensteyn

25/07/2010 15:03:04
Quote Anchor link
PHP is niet goed gecompileerd, de scripts zelf zijn goed.
Probeer het eens opnieuw?
Welke meldingen krijg je bij ./build php n?
 
Comanti Com

Comanti Com

25/07/2010 15:15:02
Quote Anchor link
Peter aka Lekensteyn op 25/07/2010 15:03:04:
Welke meldingen krijg je bij ./build php n?


Een hele bak aan tekst kwam voorbij dit is iets van het laatste:

tring/oniguruma/regsyntax.lo ext/mbstring/oniguruma/regtrav.lo ext/mbstring/oniguruma/regversion.lo ext/mbstring/oniguruma/st.lo ext/mbstring/oniguruma/enc/unicode.lo ext/mbstring/oniguruma/enc/ascii.lo ext/mbstring/oniguruma/enc/utf8.lo ext/mbstring/oniguruma/enc/euc_jp.lo ext/mbstring/oniguruma/enc/euc_tw.lo ext/mbstring/oniguruma/enc/euc_kr.lo ext/mbstring/oniguruma/enc/sjis.lo ext/mbstring/oniguruma/enc/iso8859_1.lo ext/mbstring/oniguruma/enc/iso8859_2.lo ext/mbstring/oniguruma/enc/iso8859_3.lo ext/mbstring/oniguruma/enc/iso8859_4.lo ext/mbstring/oniguruma/enc/iso8859_5.lo ext/mbstring/oniguruma/enc/iso8859_6.lo ext/mbstring/oniguruma/enc/iso8859_7.lo ext/mbstring/oniguruma/enc/iso8859_8.lo ext/mbstring/oniguruma/enc/iso8859_9.lo ext/mbstring/oniguruma/enc/iso8859_10.lo ext/mbstring/oniguruma/enc/iso8859_11.lo ext/mbstring/oniguruma/enc/iso8859_13.lo ext/mbstring/oniguruma/enc/iso8859_14.lo ext/mbstring/oniguruma/enc/iso8859_15.lo ext/mbstring/oniguruma/enc/iso8859_16.lo ext/mbstring/oniguruma/enc/koi8.lo ext/mbstring/oniguruma/enc/koi8_r.lo ext/mbstring/oniguruma/enc/big5.lo ext/mbstring/oniguruma/enc/utf16_be.lo ext/mbstring/oniguruma/enc/utf16_le.lo ext/mbstring/oniguruma/enc/utf32_be.lo ext/mbstring/oniguruma/enc/utf32_le.lo ext/mbstring/oniguruma/enc/gb18030.lo ext/mbstring/libmbfl/filters/html_entities.lo ext/mbstring/libmbfl/filters/mbfilter_7bit.lo ext/mbstring/libmbfl/filters/mbfilter_ascii.lo ext/mbstring/libmbfl/filters/mbfilter_base64.lo ext/mbstring/libmbfl/filters/mbfilter_big5.lo ext/mbstring/libmbfl/filters/mbfilter_byte2.lo ext/mbstring/libmbfl/filters/mbfilter_byte4.lo ext/mbstring/libmbfl/filters/mbfilter_cp1251.lo ext/mbstring/libmbfl/filters/mbfilter_cp1252.lo ext/mbstring/libmbfl/filters/mbfilter_cp866.lo ext/mbstring/libmbfl/filters/mbfilter_cp932.lo ext/mbstring/libmbfl/filters/mbfilter_cp936.lo ext/mbstring/libmbfl/filters/mbfilter_euc_cn.lo ext/mbstring/libmbfl/filters/mbfilter_euc_jp.lo ext/mbstring/libmbfl/filters/mbfilter_euc_jp_win.lo ext/mbstring/libmbfl/filters/mbfilter_cp51932.lo ext/mbstring/libmbfl/filters/mbfilter_euc_kr.lo ext/mbstring/libmbfl/filters/mbfilter_euc_tw.lo ext/mbstring/libmbfl/filters/mbfilter_htmlent.lo ext/mbstring/libmbfl/filters/mbfilter_hz.lo ext/mbstring/libmbfl/filters/mbfilter_iso2022_kr.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_1.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_10.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_13.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_14.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_15.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_16.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_2.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_3.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_4.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_5.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_6.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_7.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_8.lo ext/mbstring/libmbfl/filters/mbfilter_iso8859_9.lo ext/mbstring/libmbfl/filters/mbfilter_jis.lo ext/mbstring/libmbfl/filters/mbfilter_iso2022_jp_ms.lo ext/mbstring/libmbfl/filters/mbfilter_koi8r.lo ext/mbstring/libmbfl/filters/mbfilter_armscii8.lo ext/mbstring/libmbfl/filters/mbfilter_qprint.lo ext/mbstring/libmbfl/filters/mbfilter_sjis.lo ext/mbstring/libmbfl/filters/mbfilter_ucs2.lo ext/mbstring/libmbfl/filters/mbfilter_ucs4.lo ext/mbstring/libmbfl/filters/mbfilter_uhc.lo ext/mbstring/libmbfl/filters/mbfilter_utf16.lo ext/mbstring/libmbfl/filters/mbfilter_utf32.lo ext/mbstring/libmbfl/filters/mbfilter_utf7.lo ext/mbstring/libmbfl/filters/mbfilter_utf7imap.lo ext/mbstring/libmbfl/filters/mbfilter_utf8.lo ext/mbstring/libmbfl/filters/mbfilter_uuencode.lo ext/mbstring/libmbfl/mbfl/mbfilter.lo ext/mbstring/libmbfl/mbfl/mbfilter_8bit.lo ext/mbstring/libmbfl/mbfl/mbfilter_pass.lo ext/mbstring/libmbfl/mbfl/mbfilter_wchar.lo ext/mbstring/libmbfl/mbfl/mbfl_convert.lo ext/mbstring/libmbfl/mbfl/mbfl_encoding.lo ext/mbstring/libmbfl/mbfl/mbfl_filter_output.lo ext/mbstring/libmbfl/mbfl/mbfl_ident.lo ext/mbstring/libmbfl/mbfl/mbfl_language.lo ext/mbstring/libmbfl/mbfl/mbfl_memory_device.lo ext/mbstring/libmbfl/mbfl/mbfl_string.lo ext/mbstring/libmbfl/mbfl/mbfl_allocators.lo ext/mbstring/libmbfl/nls/nls_de.lo ext/mbstring/libmbfl/nls/nls_en.lo ext/mbstring/libmbfl/nls/nls_ja.lo ext/mbstring/libmbfl/nls/nls_kr.lo ext/mbstring/libmbfl/nls/nls_neutral.lo ext/mbstring/libmbfl/nls/nls_ru.lo ext/mbstring/libmbfl/nls/nls_uni.lo ext/mbstring/libmbfl/nls/nls_zh.lo ext/mbstring/libmbfl/nls/nls_hy.lo ext/mbstring/libmbfl/nls/nls_tr.lo ext/mbstring/mbstring.lo ext/mbstring/php_unicode.lo ext/mbstring/mb_gpc.lo ext/mbstring/php_mbregex.lo ext/mcrypt/mcrypt.lo ext/mhash/mhash.lo ext/mysql/php_mysql.lo ext/mysqli/mysqli.lo ext/mysqli/mysqli_api.lo ext/mysqli/mysqli_prop.lo ext/mysqli/mysqli_nonapi.lo ext/mysqli/mysqli_fe.lo ext/mysqli/mysqli_report.lo ext/mysqli/mysqli_repl.lo ext/mysqli/mysqli_driver.lo ext/mysqli/mysqli_warning.lo ext/mysqli/mysqli_exception.lo ext/mysqli/mysqli_embedded.lo ext/pdo/pdo.lo ext/pdo/pdo_dbh.lo ext/pdo/pdo_stmt.lo ext/pdo/pdo_sql_parser.lo ext/pdo/pdo_sqlstate.lo ext/pdo_mysql/pdo_mysql.lo ext/pdo_mysql/mysql_driver.lo ext/pdo_mysql/mysql_statement.lo ext/pdo_sqlite/pdo_sqlite.lo ext/pdo_sqlite/sqlite_driver.lo ext/pdo_sqlite/sqlite_statement.lo ext/pdo_sqlite/sqlite/src/attach.lo ext/pdo_sqlite/sqlite/src/auth.lo ext/pdo_sqlite/sqlite/src/btree.lo ext/pdo_sqlite/sqlite/src/build.lo ext/pdo_sqlite/sqlite/src/callback.lo ext/pdo_sqlite/sqlite/src/date.lo ext/pdo_sqlite/sqlite/src/delete.lo ext/pdo_sqlite/sqlite/src/expr.lo ext/pdo_sqlite/sqlite/src/func.lo ext/pdo_sqlite/sqlite/src/hash.lo ext/pdo_sqlite/sqlite/src/insert.lo ext/pdo_sqlite/sqlite/src/legacy.lo ext/pdo_sqlite/sqlite/src/main.lo ext/pdo_sqlite/sqlite/src/os_unix.lo ext/pdo_sqlite/sqlite/src/os_win.lo ext/pdo_sqlite/sqlite/src/os.lo ext/pdo_sqlite/sqlite/src/pager.lo ext/pdo_sqlite/sqlite/src/pragma.lo ext/pdo_sqlite/sqlite/src/prepare.lo ext/pdo_sqlite/sqlite/src/printf.lo ext/pdo_sqlite/sqlite/src/random.lo ext/pdo_sqlite/sqlite/src/select.lo ext/pdo_sqlite/sqlite/src/table.lo ext/pdo_sqlite/sqlite/src/tokenize.lo ext/pdo_sqlite/sqlite/src/analyze.lo ext/pdo_sqlite/sqlite/src/complete.lo ext/pdo_sqlite/sqlite/src/trigger.lo ext/pdo_sqlite/sqlite/src/update.lo ext/pdo_sqlite/sqlite/src/utf.lo ext/pdo_sqlite/sqlite/src/util.lo ext/pdo_sqlite/sqlite/src/vacuum.lo ext/pdo_sqlite/sqlite/src/vdbeapi.lo ext/pdo_sqlite/sqlite/src/vdbeaux.lo ext/pdo_sqlite/sqlite/src/vdbe.lo ext/pdo_sqlite/sqlite/src/vdbemem.lo ext/pdo_sqlite/sqlite/src/where.lo ext/pdo_sqlite/sqlite/src/parse.lo ext/pdo_sqlite/sqlite/src/opcodes.lo ext/pdo_sqlite/sqlite/src/alter.lo ext/pdo_sqlite/sqlite/src/vdbefifo.lo ext/pdo_sqlite/sqlite/src/vtab.lo ext/pdo_sqlite/sqlite/src/loadext.lo ext/posix/posix.lo ext/reflection/php_reflection.lo ext/session/session.lo ext/session/mod_files.lo ext/session/mod_mm.lo ext/session/mod_user.lo ext/simplexml/simplexml.lo ext/sockets/sockets.lo ext/spl/php_spl.lo ext/spl/spl_functions.lo ext/spl/spl_engine.lo ext/spl/spl_iterators.lo ext/spl/spl_array.lo ext/spl/spl_directory.lo ext/spl/spl_sxe.lo ext/spl/spl_exceptions.lo ext/spl/spl_observer.lo ext/sqlite/sqlite.lo ext/sqlite/sess_sqlite.lo ext/sqlite/pdo_sqlite2.lo ext/sqlite/libsqlite/src/opcodes.lo ext/sqlite/libsqlite/src/parse.lo ext/sqlite/libsqlite/src/encode.lo ext/sqlite/libsqlite/src/auth.lo ext/sqlite/libsqlite/src/btree.lo ext/sqlite/libsqlite/src/build.lo ext/sqlite/libsqlite/src/delete.lo ext/sqlite/libsqlite/src/expr.lo ext/sqlite/libsqlite/src/func.lo ext/sqlite/libsqlite/src/hash.lo ext/sqlite/libsqlite/src/insert.lo ext/sqlite/libsqlite/src/main.lo ext/sqlite/libsqlite/src/os.lo ext/sqlite/libsqlite/src/pager.lo ext/sqlite/libsqlite/src/printf.lo ext/sqlite/libsqlite/src/random.lo ext/sqlite/libsqlite/src/select.lo ext/sqlite/libsqlite/src/table.lo ext/sqlite/libsqlite/src/tokenize.lo ext/sqlite/libsqlite/src/update.lo ext/sqlite/libsqlite/src/util.lo ext/sqlite/libsqlite/src/vdbe.lo ext/sqlite/libsqlite/src/attach.lo ext/sqlite/libsqlite/src/btree_rb.lo ext/sqlite/libsqlite/src/pragma.lo ext/sqlite/libsqlite/src/vacuum.lo ext/sqlite/libsqlite/src/copy.lo ext/sqlite/libsqlite/src/vdbeaux.lo ext/sqlite/libsqlite/src/date.lo ext/sqlite/libsqlite/src/where.lo ext/sqlite/libsqlite/src/trigger.lo regex/regcomp.lo regex/regexec.lo regex/regerror.lo regex/regfree.lo ext/standard/array.lo ext/standard/base64.lo ext/standard/basic_functions.lo ext/standard/browscap.lo ext/standard/crc32.lo ext/standard/crypt.lo ext/standard/cyr_convert.lo ext/standard/datetime.lo ext/standard/dir.lo ext/standard/dl.lo ext/standard/dns.lo ext/standard/exec.lo ext/standard/file.lo ext/standard/filestat.lo ext/standard/flock_compat.lo ext/standard/formatted_print.lo ext/standard/fsock.lo ext/standard/head.lo ext/standard/html.lo ext/standard/image.lo ext/standard/info.lo ext/standard/iptc.lo ext/standard/lcg.lo ext/standard/link.lo ext/standard/mail.lo ext/standard/math.lo ext/standard/md5.lo ext/standard/metaphone.lo ext/standard/microtime.lo ext/standard/pack.lo ext/standard/pageinfo.lo ext/standard/quot_print.lo ext/standard/rand.lo ext/standard/reg.lo ext/standard/soundex.lo ext/standard/string.lo ext/standard/scanf.lo ext/standard/syslog.lo ext/standard/type.lo ext/standard/uniqid.lo ext/standard/url.lo ext/standard/var.lo ext/standard/versioning.lo ext/standard/assert.lo ext/standard/strnatcmp.lo ext/standard/levenshtein.lo ext/standard/incomplete_class.lo ext/standard/url_scanner_ex.lo ext/standard/ftp_fopen_wrapper.lo ext/standard/http_fopen_wrapper.lo ext/standard/php_fopen_wrapper.lo ext/standard/credits.lo ext/standard/css.lo ext/standard/var_unserializer.lo ext/standard/ftok.lo ext/standard/sha1.lo ext/standard/user_filters.lo ext/standard/uuencode.lo ext/standard/filters.lo ext/standard/proc_open.lo ext/standard/streamsfuncs.lo ext/standard/http.lo ext/tokenizer/tokenizer.lo ext/tokenizer/tokenizer_data.lo ext/xml/xml.lo ext/xml/compat.lo ext/xmlreader/php_xmlreader.lo ext/xmlwriter/php_xmlwriter.lo ext/zip/php_zip.lo ext/zip/zip_stream.lo ext/zip/lib/zip_add.lo ext/zip/lib/zip_error.lo ext/zip/lib/zip_fclose.lo ext/zip/lib/zip_fread.lo ext/zip/lib/zip_open.lo ext/zip/lib/zip_source_filep.lo ext/zip/lib/zip_strerror.lo ext/zip/lib/zip_close.lo ext/zip/lib/zip_error_get.lo ext/zip/lib/zip_file_error_get.lo ext/zip/lib/zip_free.lo ext/zip/lib/zip_rename.lo ext/zip/lib/zip_source_free.lo ext/zip/lib/zip_unchange_all.lo ext/zip/lib/zip_delete.lo ext/zip/lib/zip_error_get_sys_type.lo ext/zip/lib/zip_file_get_offset.lo ext/zip/lib/zip_get_name.lo ext/zip/lib/zip_replace.lo ext/zip/lib/zip_source_function.lo ext/zip/lib/zip_unchange.lo ext/zip/lib/zip_dirent.lo ext/zip/lib/zip_error_strerror.lo ext/zip/lib/zip_filerange_crc.lo ext/zip/lib/zip_file_strerror.lo ext/zip/lib/zip_get_num_files.lo ext/zip/lib/zip_get_archive_flag.lo ext/zip/lib/zip_set_archive_flag.lo ext/zip/lib/zip_set_name.lo ext/zip/lib/zip_source_zip.lo ext/zip/lib/zip_unchange_data.lo ext/zip/lib/zip_entry_free.lo ext/zip/lib/zip_error_to_str.lo ext/zip/lib/zip_fopen.lo ext/zip/lib/zip_name_locate.lo ext/zip/lib/zip_source_buffer.lo ext/zip/lib/zip_stat.lo ext/zip/lib/zip_entry_new.lo ext/zip/lib/zip_err_str.lo ext/zip/lib/zip_fopen_index.lo ext/zip/lib/zip_get_archive_comment.lo ext/zip/lib/zip_get_file_comment.lo ext/zip/lib/zip_new.lo ext/zip/lib/zip_source_file.lo ext/zip/lib/zip_stat_index.lo ext/zip/lib/zip_set_archive_comment.lo ext/zip/lib/zip_set_file_comment.lo ext/zip/lib/zip_unchange_archive.lo ext/zip/lib/zip_memdup.lo ext/zip/lib/zip_stat_init.lo ext/zip/lib/zip_add_dir.lo ext/zip/lib/zip_error_clear.lo ext/zip/lib/zip_file_error_clear.lo TSRM/TSRM.lo TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/main.lo main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/safe_mode.lo main/fopen_wrappers.lo main/alloca.lo main/php_scandir.lo main/php_ini.lo main/SAPI.lo main/rfc1867.lo main/php_content_types.lo main/strlcpy.lo main/strlcat.lo main/mergesort.lo main/reentrancy.lo main/php_variables.lo main/php_ticks.lo main/network.lo main/php_open_temporary_file.lo main/php_logos.lo main/output.lo main/streams/streams.lo main/streams/cast.lo main/streams/memory.lo main/streams/filter.lo main/streams/plain_wrapper.lo main/streams/userspace.lo main/streams/transports.lo main/streams/xp_socket.lo main/streams/mmap.lo Zend/zend_language_parser.lo Zend/zend_language_scanner.lo Zend/zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/zend_alloc.lo Zend/zend_compile.lo Zend/zend_constants.lo Zend/zend_dynamic_array.lo Zend/zend_execute_API.lo Zend/zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_exceptions.lo Zend/zend_strtod.lo Zend/zend_objects.lo Zend/zend_object_handlers.lo Zend/zend_objects_API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/php_cli_readline.lo sapi/cli/getopt.lo main/internal_functions_cli.lo -lcrypt -lz -lcrypt -lrt -lmysqlclient -lmhash -lmcrypt -lltdl -liconv -lfreetype -lpng -lz -ljpeg -lcurl -lz -lpcre -lresolv -lm -ldl -lnsl -lxml2 -lz -liconv -lm -lssl -lcrypto -ldl -lz -lcurl -lxml2 -lz -liconv -lm -lssl -lcrypto -ldl -lz -lmysqlclient -lz -lcrypt -lnsl -lm -lmygcc -lmysqlclient -lz -lcrypt -lnsl -lm -lmygcc -lxml2 -lz -liconv -lm -lcrypt -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lcrypt -o sapi/cli/php

Build complete.
Don't forget to run 'make test'.

Make Complete
Copying php.ini..
/usr/local/lib/php.ini already exists, skipping.
Installing php...
Installing PHP SAPI module: apache2handler
/var/www/build/instdso.sh SH_LIBTOOL='/var/www/build/libtool' libphp5.la /usr/lib/apache
/var/www/build/libtool --mode=install cp libphp5.la /usr/lib/apache/
cp .libs/libphp5.so /usr/lib/apache/libphp5.so
cp .libs/libphp5.lai /usr/lib/apache/libphp5.la
libtool: install: warning: remember to run `libtool --finish /usr/local/directadmin/custombuild/php-5.2.14/libs'
chmod 755 /usr/lib/apache/libphp5.so
[activating module `php5' in /etc/httpd/conf/httpd.conf]
Installing PHP CLI binary: /usr/local/bin/
Installing PHP CLI man page: /usr/local/man/man1/
Installing build environment: /usr/local/lib/php/build/
Installing header files: /usr/local/include/php/
Installing helper programs: /usr/local/bin/
program: phpize
program: php-config
Installing man pages: /usr/local/man/man1/
page: phpize.1
page: php-config.1
Installing PEAR environment: /usr/local/lib/php/
[PEAR] Archive_Tar - already installed: 1.3.7
[PEAR] Console_Getopt - already installed: 1.2.3
[PEAR] Structures_Graph- already installed: 1.0.3
[PEAR] XML_Util - already installed: 1.2.1
[PEAR] PEAR - already installed: 1.9.1
Wrote PEAR system config file at: /usr/local/etc/pear.conf
You may want to add: /usr/local/lib/php to your php.ini include_path
Installing PDO headers: /usr/local/include/php/ext/pdo/
Increasing memory limit to 32M...
PHP 5.2.14 Installed.
Rewriting all users httpd.conf files, please wait...
In debug mode
Debug set to level 10
root priv set: uid:0 gid:0 euid:0 egid:0
pidfile written
staring queue
done queue
Restarting apache.
Stopping httpd: [ OK ]
Starting httpd:
-bash-3.2#



Maar het probleem blijft...
Gewijzigd op 25/07/2010 15:16:01 door Comanti Com
 
Aad B

Aad B

25/07/2010 15:42:44
Quote Anchor link
Het helpt nu niet meer maar indien mogelijk op CentOS bij update van al je spullen yum gebruiken. #yum update php (en andere tools) werkt bij mij altijd probleemloos. Het zelf builden laat ik zoveel mogelijk achterwege. Uiteraard tenzij je speciale spullen mee wilt compileren, dan moet je wel. Voor wat betreft de update van ..13 naar ..14 waarom ? Release notes gelezen en je loopt tegen een bug aan of je loopt teveel risico op security ? Dan doen maar in andere gevallen: never change a winning team.
Edit:

Mogelijk kan je nu (als)nog met yum aan de slag om de zaak aan de praat te krijgen. Andere mogelijkheid: stop je vps en laat een backup terugzetten!
Gewijzigd op 25/07/2010 15:45:25 door Aad B
 
Comanti Com

Comanti Com

25/07/2010 16:03:04
Quote Anchor link
Het commando #yum update php moet ik dat nog in een bepaalde map doen?

Waarom de update naar 5.2.14? Omdat ik bij wil blijven met updates,...
 
Aad B

Aad B

25/07/2010 16:45:37
Quote Anchor link
"Omdat je bij wil blijven met updates". Als ik dat op het werk zou doen dan zou je computertje vandaag geen stroom meer hebben. Overweeg altijd zorgvuldig of je meegaat met elke subsub release. Check welk voordeel je ermee behaalt. Weinig of geen substantieel voordeel ? Dan wachten op volgende sub release. Zorg verder voor een testomgeving waarin je je update plan kan testen. Misschien ligt nu je productie omgeving op zijn gat :(
Zoek uit hoe yum werkt en gebruik yum. Je kan yum gewoon starten vanuit de home directory van root.
Gewijzigd op 25/07/2010 16:47:42 door Aad B
 
Comanti Com

Comanti Com

25/07/2010 17:12:36
Quote Anchor link
Heb gedaan wat je zei maar levert -tot op heden- niets op....

-bash-3.2# yum update php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: ftp.nluug.nl
* base: ftp.nluug.nl
* extras: ftp.nluug.nl
* rpmforge: apt.sw.be
* updates: ftp.nluug.nl
Excluding Packages in global exclude list
Finished
Setting up Update Process
No Match for argument: php
No package php available.
No Packages marked for Update
-bash-3.2# service httpd restart
Stopping httpd: [ OK ]
Starting httpd:
-bash-3.2#

heb zoals je ziet ook nog de httpd herstart maar ook dit leverde niets op...

Ja een test omgeving snap ik wel, maar het is een hobby servertje van me waarmee ik probeer ook verder te kunnen leren, er draaien wat domeinen op en wat andere hobby projecten, maar niets ernstigs...
Bij een serieuse omgeving ja dat je daar een en ander uitvoerig gaat testen dat snap ik...
 
P Lekensteyn

P Lekensteyn

25/07/2010 17:15:32
Quote Anchor link
yum is de pakketbeheerder op CentOS.
Met # bedoelt Aad dat je de commando als root user moet starten.

Met zelf bouwen heb je de meeste keuze hoor :)
Maar als je er niet veel ervaring mee hebt, dan kun je het in productieomgevingen beter andere methoden nemen.

Ik vond bouwen handiger, en heb het gewoon in VirtualBox uitgetest.
Debian op server, Debian in VirtualBox.
 
Aad B

Aad B

25/07/2010 17:20:57
Quote Anchor link
mogelijk denkt yum nu dat de laatste release al aanwezig is...
het kan ook zijn dat je even op zoek moet naar het juiste command. Je moet php wat verder uitschrijven, dus qualificeren wat je wilt update, doe maar eens:
[root@webserver]# yum search php
base 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 1.9 kB 00:00
primary.sqlite.bz2 100% |=========================| 345 kB 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 2.1 kB 00:00
php-pgsql.i386 : A PostgreSQL database module for PHP.
php-odbc.i386 : A module for PHP applications that use ODBC databases.
etc
en je moet dus de volledige string voor de punt nemen in je yum update statement.
Als laatste redmiddel kan je ook yum erase gevolgd door yum install doen.
Gewijzigd op 25/07/2010 17:21:26 door Aad B
 
Comanti Com

Comanti Com

25/07/2010 17:43:04
Quote Anchor link
Peter aka Lekensteyn op 25/07/2010 17:15:32:
yum is de pakketbeheerder op CentOS.
Met # bedoelt Aad dat je de commando als root user moet starten.



Ik ben als root user ingelogd,..


Aad B op 25/07/2010 17:20:57:
mogelijk denkt yum nu dat de laatste release al aanwezig is...
het kan ook zijn dat je even op zoek moet naar het juiste command. Je moet php wat verder uitschrijven, dus qualificeren wat je wilt update, doe maar eens:
[root@webserver]# yum search php
base 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 1.9 kB 00:00
primary.sqlite.bz2 100% |=========================| 345 kB 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 2.1 kB 00:00
php-pgsql.i386 : A PostgreSQL database module for PHP.
php-odbc.i386 : A module for PHP applications that use ODBC databases.
etc
en je moet dus de volledige string voor de punt nemen in je yum update statement.
Als laatste redmiddel kan je ook yum erase gevolgd door yum install doen.

Ik snap niet alles wat je uitlegd Aad, maar met het commando:
yum search php kreeg ik het volgende:


-bash-3.2# yum search php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: ftp.nluug.nl
* base: ftp.nluug.nl
* extras: ftp.nluug.nl
* rpmforge: apt.sw.be
* updates: ftp.nluug.nl
Excluding Packages in global exclude list
Finished
================================= Matched: php =================================
SDL_gfx.x86_64 : Graphic primitives, rotozoomer, framerate control and image
: filters
SDL_gfx-devel.x86_64 : Header files, libraries and development documentation for
: SDL_gfx
arpd.x86_64 : ARP reply daemon
arphound.x86_64 : ARP traffic monitoring/logging tool
arping2.x86_64 : Layer2 Ethernet pinger
atomorun.x86_64 : OpenGL Jump&Run game where you have to flee an exploding
: nuclear bomb
blobwars.x86_64 : Mission and Objective based 2D Platform Game
bluefish.x86_64 : Graphical web development application for experienced users
cabextract.x86_64 : Program to extract Microsoft Cabinet files
cacti.noarch : Complete network graphing solution designed on top of RRDTool
compat-readline43.i386 : The readline 4.3 library for compatibility with older
: software.
compat-readline43.x86_64 : The readline 4.3 library for compatibility with older
: software.
critter.x86_64 : SDL/OpenGL space shoot'em up game
dnstracer.x86_64 : Trace a chain of DNS servers to the source
dynamite.x86_64 : Extract data compressed with PKWARE Data Compression Library
dynamite-devel.x86_64 : Header files, libraries and development documentation
: for dynamite.
evolution-rss.x86_64 : Evolution plugin for rss feed support
fonts-arabic.noarch : Fonts for Arabic
fortune-taow.x86_64 : Fortune files with quotes from Sun Tzu's "The Art of War"
fraqtive.x86_64 : Draws Mandelbrot and Julia fractals
fuse-iso.x86_64 : FUSE module to mount ISO filesystem images
geany.x86_64 : Small C editor
gnome-themes-extras.noarch : Collection of metathemes for the Gnome desktop
: environment
gollem-h3.noarch : The Horde web-based File Manager.
gonvert.noarch : Units conversion utility
graphviz-php.x86_64 : Php extension tools for version 2.8 of graphviz
gtk-murrine-engine.x86_64 : Murrine GTK2 engine
gtodo.x86_64 : Graphical todo list tool
hddtemp.x86_64 : Hard disk temperature tool
horde.noarch : The common Horde Framework for all Horde modules.
icinga-api.x86_64 : PHP api for icinga
imp-h3.noarch : The Internet Messaging Program: webmail access to IMAP/POP3
: accounts.
ingo-h3.noarch : The Horde web-based Email Filter Rules Manager.
iproute.x86_64 : Advanced IP routing and network device configuration tools.
ipw2100-firmware.noarch : Firmware for Intel? PRO/Wireless 2100 network adaptors
ipw2200-firmware.noarch : Firmware for Intel? PRO/Wireless 2200 network adaptors
kboggle.x86_64 : Boggle game
kflamesaver.x86_64 : Screensaver with flames
kiosktool.x86_64 : KIOSK administration admin tool
kronolith-h3.noarch : The Horde calendar application.
lbzip2.x86_64 : Parallel implementation of the bzip2 file compressor
libc-client.i386 : C-client mail access routines for IMAP and POP protocols
libc-client.x86_64 : C-client mail access routines for IMAP and POP protocols
libmpeg3.x86_64 : Decoder of various derivatives of MPEG standards
libmpeg3-devel.x86_64 : Development files for libmpeg3
libmpeg3-utils.x86_64 : Utilities from libmpeg3
libnxml.x86_64 : Library for parsing, writing and creating XML
libnxml-devel.x86_64 : Header files, libraries and development documentation for
: libnxml.
lighttpd-fastcgi.x86_64 : FastCGI module and spawning helper for lighttpd and
: PHP configuration
mmsrip.x86_64 : MMS Streams Recorder
mnemo-h3.noarch : The Horde note manager application.
nag-h3.noarch : The Horde task list manager.
ntop.x86_64 : Network traffic probe that shows the network usage
nttlscan.x86_64 : Quick network topology scanner
perl-Captcha-reCAPTCHA.noarch : A Perl implementation of the reCAPTCHA API
perl-PHP-Perlinfo.noarch : Clone of PHP's phpinfo function for Perl
perl-PHP-Serialization.noarch : Convert PHP's serialize() output into Perl
: memory structure, and back.
perl-PLP.noarch : Perl in HTML pages
perl-XML-Mini.noarch : MiniXML XML generator and parser interface
phc.x86_64 : PHP compiler
postgresql-relay.x86_64 : Multiplex all your databases to one point of origin
premiereepg2vdr.x86_64 : Read EPG information for Premiere TV channels
python-kid.noarch : Simple and pythonic XML template language
rbme.noarch : Rsync Backup Made Easy
readline.i386 : A library for editing typed command lines.
readline.x86_64 : A library for editing typed command lines.
readline-devel.i386 : Files needed to develop programs which use the readline
: library.
readline-devel.x86_64 : Files needed to develop programs which use the readline
: library.
sarg.x86_64 : Squid usage report generator per user/ip/name
sharedance.x86_64 : Ephemeral key/data pair storing daemon
sphinx.x86_64 : Free open-source SQL full-text search engine
sqlitemanager.noarch : Multilingual web based tool to manage SQLite database
squirrelmail.noarch : SquirrelMail webmail client
talkfilters.x86_64 : converts ordinary English text into text that mimics a
: certain dialect
talkfilters-devel.x86_64 : Header files, libraries and development documentation
: for talkfilters.
totem.i386 : Movie player for GNOME 2
totem.x86_64 : Movie player for GNOME 2
totem-devel.i386 : Libraries/include files for Totem
totem-devel.x86_64 : Libraries/include files for Totem
totem-mozplugin.x86_64 : Mozilla plugin for Totem
turba-h3.noarch : The Horde contact management application.
velocity.x86_64 : Java-based template engine
viruskiller.x86_64 : Frantic shooting game where viruses invade your computer
xaos.x86_64 : Fast, portable, real-time, and interactive fractal zoomer
-bash-3.2#
 
Aad B

Aad B

25/07/2010 18:39:35
Quote Anchor link
Probeer eens:
#yum upgrade php-common
en
#yum upgrade php-mysql

Je probeert dan een upgrade voor: php-common.i386 : Common files for PHP en MySQL
 
Comanti Com

Comanti Com

25/07/2010 19:58:05
Quote Anchor link
-bash-3.2# yum upgrade php-common
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: ftp.nluug.nl
* base: ftp.nluug.nl
* extras: ftp.nluug.nl
* rpmforge: apt.sw.be
* updates: ftp.nluug.nl
Excluding Packages in global exclude list
Finished
Setting up Upgrade Process
No Match for argument: php-common
No package php-common available.
No Packages marked for Update
-bash-3.2#

-bash-3.2# yum upgrade php-mysql
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: ftp.nluug.nl
* base: ftp.nluug.nl
* extras: ftp.nluug.nl
* rpmforge: apt.sw.be
* updates: ftp.nluug.nl
Excluding Packages in global exclude list
Finished
Setting up Upgrade Process
No Match for argument: php-mysql
No package php-mysql available.
No Packages marked for Update
-bash-3.2#

Ook niet dus... Nog meer opties?
 
Aad B

Aad B

25/07/2010 21:29:04
Quote Anchor link
Hmmm, nee. yum misschien niet goed geconfigureerd. Je hoort dit te krijgen:
Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
[root@webserver]# yum upgrade php
base                      100% |=========================| 2.1 kB    00:00
updates                   100% |=========================| 1.9 kB    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 2.1 kB    00:00
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package php.i386 0:5.1.6-27.el5 set to be updated
--> Processing Dependency: php-cli = 5.1.6-27.el5 for package: php
--> Processing Dependency: php-common = 5.1.6-27.el5 for package: php
--> Running transaction check
---> Package php-common.i386 0:5.1.6-27.el5 set to be updated
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-gd
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-pdo
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-mysql
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-ldap
---> Package php-cli.i386 0:5.1.6-27.el5 set to be updated
--> Running transaction check
---> Package php-gd.i386 0:5.1.6-27.el5 set to be updated
---> Package php-pdo.i386 0:5.1.6-27.el5 set to be updated
---> Package php-ldap.i386 0:5.1.6-27.el5 set to be updated
---> Package php-mysql.i386 0:5.1.6-27.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 php                     i386       5.1.6-27.el5     base              2.3 M
 php-cli                 i386       5.1.6-27.el5     base              2.1 M
 php-common              i386       5.1.6-27.el5     base              152 k
Updating for dependencies:
 php-gd                  i386       5.1.6-27.el5     base              117 k
 php-ldap                i386       5.1.6-27.el5     base               37 k
 php-mysql               i386       5.1.6-27.el5     base               86 k
 php-pdo                 i386       5.1.6-27.el5     base               65 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       7 Package(s)
Remove       0 Package(s)

Total download size: 4.8 M
Is this ok [y/N]:


check in de directory /etc/yum.repos.d:
CentOS-Base.repo
dit is de config file en ik heb de inhoud in een PM gezet.
Gewijzigd op 25/07/2010 21:55:11 door Aad B
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.