SSH terminal op OS X

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Pagina: 1 2 volgende »

Jan Graneker

Jan Graneker

16/03/2017 08:47:25
Quote Anchor link
Goedemorgen Leden,

Sinds een tijdje ben ik bezig met SSH. Op de server heb ik mijn werk ip en zakelijk ip toegevoegd aan de whitelist.
Vervolgens met OSX op het werk verbonden en dit was geen probleem. Bij het verbinden thuis kreeg ik steeds opnieuw de melding:

"Operation timed out"

Ook bij het uitzetten van de Fireball (tijdelijk) levert dit hetzelfde resultaat op.

Wat zou het nog meer kunnen zijn? Ik ga er niet vanuit dat het ergens in de wifi connectie moet zitten. Wat denken jullie?
 
PHP hulp

PHP hulp

22/04/2024 05:35:41
 
- Ariën  -
Beheerder

- Ariën -

16/03/2017 09:01:26
Quote Anchor link
In mijn eerste ingeving denk ik aan port-forwarding welke mogelijk niet goed is ingesteld?
 
Ivo P

Ivo P

16/03/2017 09:06:52
Quote Anchor link
port forwarding hoort in de laatste stappen voor de server te gebeuren. Dat het werkt vanaf een andere locatie, zou betekenen dat de server kant ok is.

Je hebt iets met een whitelist gedaan. Klopt dat ipadres?

Kun je de whitelist uitschakelen en alle ipadressen (tijdelijk) toegang geven (zonder password komt men toch niet direct verder) (en schakel ook toegang voor de user root en admin uit: die liggen nogal voor de hand op te bruteforcen, waar de user Jan minder voor de hand ligt.)

Kun je vanaf je eigen locatie wel connecten met andere servers via ssh (ook al heb je daar geen password voor.)

Toevoeging op 16/03/2017 09:07:37:

is jouw zakelijk-ip gelijk aan "thuis"?
 
Jan Graneker

Jan Graneker

16/03/2017 09:39:51
Quote Anchor link
@ Arien ik heb de port-forwarding op mijn router aangezet.

Afbeelding


@ Ivo, klopt ik ga er vanuit dat de server kant oke is, omdat ik al meerdere malen het verbonden via de MAC en PuTTY.

Ik kan de whitelist nog even checken samen met het uitschakelen.

Ik ga ook gelijk kijken of ik via hier naar een andere shell kan verbinden.


Nee, mijn zakelijk-ip is anders dan thuis.
Gewijzigd op 16/03/2017 09:41:24 door Jan Graneker
 
Ben van Velzen

Ben van Velzen

16/03/2017 10:47:16
Quote Anchor link
Op je router thuis heeft port forwarding geen zin, dit zal aan de serverkant moeten gebeuren.
 
- Ariën  -
Beheerder

- Ariën -

16/03/2017 11:36:27
Quote Anchor link
Daarom, het was mij niet duidelijk of je nou vanuit werk of huis geen verbinding kreeg met SSH.
 
Ivo P

Ivo P

16/03/2017 13:33:42
Quote Anchor link
ofwel kom je niet "naar buiten" vanaf de pc thuis

ofwel accepteert (het netwerk van) de server geen verbindingen vanaf jouw thuis-locatie.

1) is te controleren door een andere server te benaderen via poort 22 (ssh)

2) begin met je firewall op de server niet te strak te zetten en/of de logs daarvan te controleren.
 
- SanThe -

- SanThe -

16/03/2017 18:47:09
Quote Anchor link
Kan je de server wel pingen?

ping serveripnummer
 
Dennis WhoCares

Dennis WhoCares

16/03/2017 20:00:42
Quote Anchor link
Hi Jan,

ik ben er vrijwel zeer zeker van dat er naar de forwarsing gekeken moet worden op de firewall van het werk.
pingen verteld vrijwel niks (als dat wel aan staat) alleen dat de firewall op het werk aan staat, maar niks over de server.

Ik ben alleen bang dat ze ( IT ) dit niet zal toestaan wegens beveiligingsredenen.
Wellicht is een VPN een betere oplossing om verbinding te maken met het netwerk op je werk?

success!
 
Ivo P

Ivo P

16/03/2017 21:03:04
Quote Anchor link
waar staat die server?
wat is werk ip?
wat is zakelijk ip?
en wat is thuis?

zoals ik het zie:
Er is ergens op het internet een server te vinden.
Jij werkt ergens en als je dan internet op gaat, dan doe je dat via een zeker ip adres.
Dan is er een zakelijk ip wat mij niet duidelijk is.

En tenslotte ben je ook wel eens thuis. En als je dan internet op gaat dan gebruik je een verbinding via adsl van Online.

En dan is er op de server nog een firewall die alles blokt behalve een werk ip en een zakelijk ip.

Tenzij zakelijk-ip = thuis, denk ik dat de firewall op je server een ip mist in de whitelist.
 
Jan Graneker

Jan Graneker

17/03/2017 08:12:15
Quote Anchor link
Bedankt voor de vele goede reacties!

Hierbij nog even een duidelijke uitleg.

SSH toegang heb ik voor de volgende ip's gewhitelist:

- Thuis
- Werk

Zodat ik altijd via deze 2 locaties met SSH kan verbinden.

Nu heb ik op het werk een Windows PC en verkrijg ik toegang met SmarTTY. Dit werkt zonder problemen.

Ook heb ik mijn Macbook meegenomen naar het werk en gebruik ik de terminal om te verbinden, ook dit werkt zonder problemen.

Als ik thuis met mijn Macbook wil verbinden blijf ik steeds de "Time out" melding krijgen. Ik heb de firewal uitgezet, maar dit hielp helaas niets.
 
Dennis WhoCares

Dennis WhoCares

17/03/2017 08:31:13
Quote Anchor link
Jan Graneker op 17/03/2017 08:12:15:
Nu heb ik op het werk een Windows PC en verkrijg ik toegang met SmarTTY. Dit werkt zonder problemen.

...

Als ik thuis met mijn Macbook wil verbinden blijf ik steeds de "Time out" melding krijgen. Ik heb de firewal uitgezet, maar dit hielp helaas niets.



Hi Jan,

heb je Windows PC ook thuis ? :)
 
Ivo P

Ivo P

17/03/2017 09:28:48
Quote Anchor link
en waar staat die server nu?

"ergens in een datacenter"?
of op kantoor in de serverruimte?
 
Jan Graneker

Jan Graneker

17/03/2017 11:59:32
Quote Anchor link
Ivo P op 17/03/2017 09:28:48:
en waar staat die server nu?

"ergens in een datacenter"?
of op kantoor in de serverruimte?


Server staat in een datacenter.

Ik denk aan 2 dingen:

1. Whitelisten is niet goed gegaan.
2. Verbinding thuis klopt iets niet mee en de firewall is uitgesloten.
Gewijzigd op 17/03/2017 12:14:59 door Jan Graneker
 
Dennis WhoCares

Dennis WhoCares

17/03/2017 16:00:38
Quote Anchor link
Ik zou de IT van de datacenter contacteren voor firewall rules.
Zorg dat je het correcte externe IP van je thuis doorgeef, en vraag om deze toe te staan in de firewall naar de server waar je mee werkt.
 
Jan Graneker

Jan Graneker

18/03/2017 12:36:43
Quote Anchor link
Ik heb het volgende geprobeerd:

Hier pakte hij de connectie wel op:

MacBook-Pro-van-Jan:~ jan$ ssh -T [email protected]
Permission denied (publicly).

Directe SSH naar Github (voorbeeld om de connectie te checken)

MacBook-Pro-van-Jan:~ jan$ ssh 192.30.252.1
ssh: connect to host 192.XX.XXX.X port 22: Operation timed out

Mijn server:

MacBook-Pro-van-Jan:~ jan$ ssh 5.XX.XXX.XX
ssh: connect to host 5.xx.xxx.xx port 22: Operation timed out
Gewijzigd op 18/03/2017 12:38:34 door Jan Graneker
 
Ivo P

Ivo P

18/03/2017 12:46:42
Quote Anchor link
Dus je komt wel naar buiten, maar bij die 2 servers niet naar binnen.

Vanaf een andere locatie kom je wel op die 192 en 5 ip adressen binnen.

Vanaf mijn locatie zie ik wel een server achter 192... maar zegt hij dat alle poorten gefilterd zijn.
 
Dennis WhoCares

Dennis WhoCares

18/03/2017 12:49:24
Quote Anchor link
Hi jan,
ik neem aan dat die server op het netwerk van je werk is aangesloten.
Daarbij adviseer ik je om aan de IT op je werk een VPN verbinding aan te vragen.

Dan kan je vanaf overal waar je bent VPN verbinding maken naar je werk. En dan zul je zonder problemen kunnen verbinden naar je server via ssh.

Ik ben ervan overtuigt dat deze topic buiten jouw 'machtigingen' valt en dus bij je lokale IT behoort.
 
Jan Graneker

Jan Graneker

18/03/2017 13:34:15
Quote Anchor link
Dennis WhoCares op 18/03/2017 12:49:24:
Hi jan,
ik neem aan dat die server op het netwerk van je werk is aangesloten.
Daarbij adviseer ik je om aan de IT op je werk een VPN verbinding aan te vragen.

Dan kan je vanaf overal waar je bent VPN verbinding maken naar je werk. En dan zul je zonder problemen kunnen verbinden naar je server via ssh.

Ik ben ervan overtuigt dat deze topic buiten jouw 'machtigingen' valt en dus bij je lokale IT behoort.



Hallo Dennis,

Nee, de server staat gewoon in een datanetwerk en zou dus vanaf elke locatie beschikbaar moeten zijn (die ik natuurlijk whitelist).

Deze heb ik via mijnip.nl gecheckt, dus ik neem aan dat dit de goede is ip.




Toevoeging op 18/03/2017 13:38:14:

Ook nog even op een andere manier geprobeerd:

MacBook-Pro-van-Jan:~ jan$ ssh -v 5.xx.xxx.xx
OpenSSH_6.9p1, LibreSSL 2.1.8
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 21: Applying options for *
debug1: Connecting to 5.xx.xxx.xx [5.xx.xxx.xx] port 22.

en de route getraced;

traceroute to 5.xx.xxx.xx , 64 hops max, 52 byte packets
1 192.168.1.1 (192.168.1.1) 5.585 ms 1.300 ms 1.111 ms
2 bng1-asdxx.nl.euro.net (194.xx.x.xx) 33.435 ms 34.978 ms 33.498 ms
3 194.xx.xxx.xxx (194.xxx.xxx.xxx) 32.710 ms 32.936 ms 32.699 ms
4 ae0.brx-asdx.nl.euro.net (194.xxx.xxx.xxx) 33.620 ms 33.372 ms 34.096 ms
5 xxx.network.bit.nl (80.xxx.xxx.xx) 34.474 ms 34.704 ms 34.544 ms

Ook heb ik het TELNET command geprobeerd daar krijg ik het volgende op terug:

telnet: Unable to connect to remote host


EDIT 150:P

Ik kan wel naar een andere server connecten. Het moet dus wel aan mijn eigen server liggen...



Toevoeging op 18/03/2017 13:50:02:

Jan Graneker op 18/03/2017 13:34:15:
Dennis WhoCares op 18/03/2017 12:49:24:
Hi jan,
ik neem aan dat die server op het netwerk van je werk is aangesloten.
Daarbij adviseer ik je om aan de IT op je werk een VPN verbinding aan te vragen.

Dan kan je vanaf overal waar je bent VPN verbinding maken naar je werk. En dan zul je zonder problemen kunnen verbinden naar je server via ssh.

Ik ben ervan overtuigt dat deze topic buiten jouw 'machtigingen' valt en dus bij je lokale IT behoort.



Hallo Dennis,

Nee, de server staat gewoon in een datanetwerk en zou dus vanaf elke locatie beschikbaar moeten zijn (die ik natuurlijk whitelist).

Deze heb ik via mijnip.nl gecheckt, dus ik neem aan dat dit de goede is ip.




Toevoeging op 18/03/2017 13:38:14:

Ook nog even op een andere manier geprobeerd:

MacBook-Pro-van-Jan:~ jan$ ssh -v 5.xx.xxx.xx
OpenSSH_6.9p1, LibreSSL 2.1.8
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 21: Applying options for *
debug1: Connecting to 5.xx.xxx.xx [5.xx.xxx.xx] port 22.

en de route getraced;

traceroute to 5.xx.xxx.xx , 64 hops max, 52 byte packets
1 192.168.1.1 (192.168.1.1) 5.585 ms 1.300 ms 1.111 ms
2 bng1-asdxx.nl.euro.net (194.xx.x.xx) 33.435 ms 34.978 ms 33.498 ms
3 194.xx.xxx.xxx (194.xxx.xxx.xxx) 32.710 ms 32.936 ms 32.699 ms
4 ae0.brx-asdx.nl.euro.net (194.xxx.xxx.xxx) 33.620 ms 33.372 ms 34.096 ms
5 xxx.network.bit.nl (80.xxx.xxx.xx) 34.474 ms 34.704 ms 34.544 ms

Ook heb ik het TELNET command geprobeerd daar krijg ik het volgende op terug:

telnet: Unable to connect to remote host


EDIT 150:P

Ik kan wel naar een andere server connecten. Het moet dus wel aan mijn eigen server liggen...


Gewijzigd op 18/03/2017 13:49:25 door Jan Graneker
 
Ben van Velzen

Ben van Velzen

18/03/2017 14:01:30
Quote Anchor link
Heb je nog aparte iptables regels die SSH access verbiedt?
 
Jan Graneker

Jan Graneker

18/03/2017 14:22:34
Quote Anchor link
Ben van Velzen op 18/03/2017 14:01:30:
Heb je nog aparte iptables regels die SSH access verbiedt?


Ja hij verbiedt elke IP, alleen de gene die ik gewhitelist heb hebben toegang.

Op de whitelist staan mijn mijn IP op het werk en mijn IP thuis.
 

Pagina: 1 2 volgende »



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.