Virtuele server maken met MAMP lukt niet

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Systeembeheerder met programmeer skills

Systeembeheerder Fulltime, Capelle aan den Ijssel De functie: De Systeembeheerder met programmeer skills is verantwoordelijk voor alle systemen binnen de datacenters. De werkzaamheden: Beleidsplannen van de Directie uitvoeren op operationeel en tactisch niveau van het Datacenter. Systemen beheren zoals: telefooncentrale, toegangssysteem, webservers, MySQL etc. Dagelijkse controle ronde lopen door de datacenter van Databarn Rivium. Planningen maken m.b.t. inrichten, verhuizen en vervangen van apparatuur. Voorbereiden en inrichten rackspace n.a.v. nieuwe klant of uitbreiding huidige klant. Eerste aanspreekpunt voor bestaande en potentiële klanten. (telefonisch en mail) Klanten informeren van geplande onderhoudsmomenten, storingen en wijzigingen. Programmeren van eigen software pakketten. Website Databarn onderhouden.

Bekijk vacature »

Jan Kila

Jan Kila

29/03/2020 10:50:55
Quote Anchor link
Een virtual host aan de gang krijgen op m’n Mac is lastiger dan ik dacht; een beetje hulp is dan ook zeer welkom. Het volgende heb ik gedaan:
1.
Het poortnummer laat ik op 3000 staan. In MAMP is dat sowieso niet zomaar te veranderen naar 80.
2.
In: ‘Apps > MAMP > conf > apache > httpd.conf’, commentarieer ik de volgende regel uit:
# Virtual hosts
Include /Applications/MAMP/conf/apache/extra/httpd-vhosts.conf
Ik stel vast dat MAMP staat te luisteren op poort: 3000
3.
In: ‘Apps > MAMP > conf > apache > extra > httpd-vhosts.conf’ plaats ik de volgende regels:
<VirtualHost *:3000>
DocumentRoot "/Applications/MAMP/design"
ServerName design
</VirtualHost>

<VirtualHost *:3000>
DocumentRoot "/Applications/MAMP/admin"
ServerName admin
</VirtualHost>
4.
In: ‘Apps > MAMP’ maak ik twee mappen:
Apps > MAMP > design
Apps > MAMP > admin
5.
In elke map zet ik een index.php met wat text.
6.
Ik herstart de servers en vul in de URL-bar van de browser in:
localhost:3000/admin + enter
Ik krijg de volgende melding:
Not Found
The requested URL /admin/ was not found on this server.

Wat doe ik fout, niet, of onvoldoende?
Elke hulp is welkom

Toevoeging op 29/03/2020 10:53:31:

O ja, het bestand 'hosts' bevat:
##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
127.0.0.1 design
127.0.0.1 admin
 
PHP hulp

PHP hulp

26/05/2020 12:06:15
 
Bart V B

Bart V B

29/03/2020 10:57:29
Quote Anchor link
Gewoon een wilde gok, maar moet hij geen extensie hebben?
dus 127.0.0.1 localhost design.loc

en dan in je virtualhost:
DocumentRoot "/Applications/MAMP/design.loc

herstarten.
en dan : http://design.loc
Gewijzigd op 29/03/2020 10:59:27 door Bart V B
 
- Ariën -
Beheerder

- Ariën -

29/03/2020 10:58:12
Quote Anchor link
Probeer eens met localhost als servername?
Of je juiste hostname mét extentie.
Gewijzigd op 29/03/2020 10:59:00 door - Ariën -
 
Jan Kila

Jan Kila

29/03/2020 11:10:35
Quote Anchor link
@ Bart,
Die heb ik al geprobeerd, lukt ook niet.
Wanneer is doe: 'http://design' dan krijg ikhet standaard bericht van Apache: 'It Work's'; en dat staat niet in mijn index.php
@ Arien,
Wat bedoel je concreet?
 
Bart V B

Bart V B

29/03/2020 11:14:45
Quote Anchor link
in hosts moet het zijn 127.0.0.1 localhost design

<VirtualHost *:3000>
DocumentRoot /Applications/MAMP/design
ServerName design
</VirtualHost>
Gewijzigd op 29/03/2020 11:16:17 door Bart V B
 
Jan Kila

Jan Kila

29/03/2020 11:26:57
Quote Anchor link
@ Bart,
Geprobeerd: werkt niet.
Je schrijft: 'DocumentRoot /Applications/MAMP/design', zonder aanhalingstekens; in de tut die ik volgde legt men er de nadruk op dat er juist wel aanhalingstekens moeten staan. Hoe zit dat?
 
- Ariën -
Beheerder

- Ariën -

29/03/2020 11:30:08
Quote Anchor link
De Apache Docs zeggen dat het moet.
 
Bart V B

Bart V B

29/03/2020 11:32:19
Quote Anchor link
Er moeten wel aanhalingstekens omheen. Dus DocumentRoot "/Applications/MAMP/design"
- Open terminal.
- type in: wget http://design

kijk eens welk ip en poort hij ophaald.
 
Jan Kila

Jan Kila

29/03/2020 11:36:45
Quote Anchor link
Password:
sudo: wget: command not found
In welke directory met ik dat commando uitvoeren?
 
Bart V B

Bart V B

29/03/2020 11:38:47
Quote Anchor link
maakt even niet uit.
- sudo apt-get install wget
en dan
wget http://design
 
Thomas van den Heuvel

Thomas van den Heuvel

29/03/2020 11:39:57
Quote Anchor link
3000 is een niet-standaard poort (voor HTTP), dus wellicht heb je met http://design:3000/ etc meer succes.

Onder Windows is er ook een executable (bin\httpd.exe) waarmee je met de -S flag (of -t) de syntax van de vhosts file kunt controleren. Er is ongetwijfeld een equivalent voor de Mac.

Mogelijk moet je ook een <Directory> directive binnen de VirtualHost aanmaken om expliciet privileges te geven voor die directories, anders krijg je mogelijk 403 Forbidden foutmeldingen.
Gewijzigd op 29/03/2020 11:44:57 door Thomas van den Heuvel
 
Jan Kila

Jan Kila

29/03/2020 11:40:28
Quote Anchor link
imac-van-jan:~ janhkila$ sudo apt-get install wget
sudo: apt-get: command not found
imac-van-jan:~ janhkila$
 
Bart V B

Bart V B

29/03/2020 11:42:29
Quote Anchor link
Ah kak das waar ook kent ie niet meer.
brew install wget

mocht brew niet zijn geïnstalleerd:
/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
Gewijzigd op 29/03/2020 11:44:16 door Bart V B
 
Jan Kila

Jan Kila

29/03/2020 11:44:13
Quote Anchor link
@ Thomas
Je bent een life saver man! 'http://design:3000/' werkt!
Ik weet niet waarom, maar het werkt.
 
Thomas van den Heuvel

Thomas van den Heuvel

29/03/2020 11:46:23
Quote Anchor link
Nou ja, dat is de poort waar MAMP staat te luisteren, kan wel voor poortje 80 (default) staan te roepen, maar daar luistert niemand :p.
 
Jan Kila

Jan Kila

29/03/2020 11:49:57
Quote Anchor link
Heren,
Mijn dank is groot; dit maakt het leven in deze moeilijke tijden weer iets aangenamer.

Toevoeging op 29/03/2020 11:53:54:

@Thomas,
OK, nu valt het kwartje!
Ik zie (nu pas) de analogie met: localhost:3000.

Toevoeging op 29/03/2020 11:58:29:

En dan is het toch wel zaak om die poort op default 80 te zetten; scheelt weer typewerk.
Dat is trouwens wel een operatie middels terminal die ik even goed moet bekijken.
MAMP heeft wellicht niet zomaar een andere poort gekozen dan de default.
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.