jQuery 2.0 uitgebracht

Toegevoegd door - Raoul -, 10 jaar geleden

jQuery 2.0 uitgebrachtVandaag heeft het jQuery-team de nieuwe versie van het populaire javascript framework uitgebracht. De grootste aanpassing in de nieuwe versie is het laten vallen van Internet Explorer 6, 7 en 8. Daardoor is jQuery nu 12% kleiner in bestandsgrootte, wat dus ook de laadtijd bevorderd.

Op de website van jQuery kun je nu meer onderdelen apart downloaden. Zo kun je dus jQuery onderdelen die je niet nodig hebt uit je uiteindelijke package laten.

De API van de vorige versie, jQuery 1.9.1 is wel nog steeds compatibel met 2.0. Het jQuery-team raad wel aan om gebruik te maken van een migrate plugin.

De volledige changelog van de nieuwe versie kun je op de blog van jQuery lezen.

Gerelateerde nieuwsberichten

19/06/2015 Goedkeuring voor standaard Javascript 6
04/07/2013 JavaScript altijd aan vanaf Mozilla Firefox 23
06/09/2012 Symfony Framework 2.1 is een feit

 

Er zijn 11 reacties op 'Jquery 20 uitgebracht'

PHP hulp
PHP hulp
0 seconden vanaf nu
 

Gesponsorde koppelingen
Landleven Tips
Landleven Tips
10 jaar geleden
 
0 +1 -0 -1
Handig dat jQuery nu de laadtijd bevorderd. Ik zal zelf nog een tijd bij jQuery 1.9.1 blijven aangezien een groot deel van mijn website gebruikers IE 7/8 gebruiken.

Het is wel zeer handig zat ze nu een package keuze hebben, weer een grote stap vooruit.
Kees Schepers
kees Schepers
10 jaar geleden
 
0 +1 -0 -1
Mwah die package keuze vindt ik niet zo belangrijk gezien ik vaak jQuery van een CDN gebruik, uiteindelijk is dat sneller. Verder wel goed dat ze IE 6 en 7 droppen maar 8 is nog NET ietsjes te vroeg voor mij. Ik zie mezelf over een half jaar wel overstappen!
Albert de Wit
Albert de Wit
10 jaar geleden
 
0 +1 -0 -1
Jammer dat ze die droppen. Veel mensen gebruiken die browsers jammergenoeg nog. (Hoe kan het dat mensen nog steeds in dat tijdperk leven?)
-Jens -
-Jens -
10 jaar geleden
 
0 +1 -0 -1
Zonde idd, ik geloof zelfs dat IE8 de meest nieuwe versie op windows xp is...
Roel -
Roel -
10 jaar geleden
 
0 +1 -0 -1
Klopt, Internet Explorer is de "nieuwste" versie voor Windows XP. Ik zie mezelf eerlijk gezegd nog geen 2.0 gebruiken, aangezien je toch een deel van je bezoekers in de steek laat op deze manier.
Landleven Tips
Landleven Tips
10 jaar geleden
 
0 +1 -0 -1
Ie 8 is inderdaad de nieuwste versie voor windows xp, eigelijk vind ik steeds meer browser discriminatie voorkomen oa door dit, maar ook andere websites die dan niet werken door je 'oude' browser..
Wouter J
Wouter J
10 jaar geleden
 
0 +1 -0 -1
Jammer...

Waarom is jQuery gemaakt? Inderdaad, om browser verschillen weg te werken. Ipv 4 verschillende methods en vele ifjes om te kijken voor support hebben we nu maar 1 functie die dit allemaal voor ons bekijkt.

Dus ik begrijp totaal niet wat de jQuery team members bezielde om te bedenken dat de browsers die het meeste afwijken van de huidige standaarden maar ook niet gesupport moeten worden door jQuery?
Als je alleen browser support die toch al hetzelfde doen wordt jQuery toch niks meer dan de 1e functie naar de andere functie mappen?

En een van de jQuery projectleiders heeft al aangegeven dat de oude Android browsers nu de zwakste schakel zijn. Het zal me niet verbazen als die er volgend jaar ook weer uitvliegt. Nog even en jQuery is niks meer waard.

En waarom? Om 'file size' te beperken? Ik denk dat het module systeem meer dan genoeg is om dit te bereiken.
Phpnuke r
phpnuke r
10 jaar geleden
 
0 +1 -0 -1
Wouter,:
------------------------
De API van de vorige versie, jQuery 1.9.1 is wel nog steeds compatibel met 2.0. Het jQuery-team raad wel aan om gebruik te maken van een migrate plugin.
-----------------

< dit

Meldt dat je dezelfde versie ook gewoon met inclusief IE kan krijgen. De keuze word dus bij ons gelegt of we IE willen ondersteunen of niet. Altans: zo zie ik het.

Een voorbeeld is bijvoorbeeld een volledige html5 website met animaties alles. Dit is vrijwel onmogelijk voor ie8=<.
Wouter J
Wouter J
10 jaar geleden
 
0 +1 -0 -1
jQuery 1.9 wordt alleen gesupport. Dat betekend dat er altijd bugs in die versie worden veranderd, nieuwe features komen er niet meer in.
Dus misschien is jQuery 1.9 en 2.0 nog wel hetzelfde, maar 1.9 en 2.1 niet meer.
Mark Hogeveen
Mark Hogeveen
10 jaar geleden
 
0 +1 -0 -1
Wouter heeft een heel goed punt...
PHP hulp
PHP hulp
0 seconden vanaf nu
 

Gesponsorde koppelingen
Eeyk Vd noot
Eeyk Vd noot
10 jaar geleden
 
0 +1 -0 -1
Zojuist geüpdatet merk niet veel qua snelheid. 0.18 naar 0.16 maar dat kan ook gewoon toeval zijn.

Om te reageren heb je een account nodig en je moet ingelogd zijn.

Labels

PHP nieuws opties

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.