symfony2 Block Bundle

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Senior Developer Betty Blocks Blauwe Haven Rotterd

Functieomschrijving Voor de Politie zijn wij opzoek naar een Senior Developer Betty Blocks Blauwe Haven Rotterdam. De politieorganisatie heeft jaarlijks te maken met een aanzienlijk aantal politiemedewerkers die vanwege mentale overbelasting niet of beperkt inzetbaar zijn. De Blauwe Haven Rotterdam ondersteunt deze politiemedewerkers in hun herstel en re-integratieproces. De huidige digitale systemen van de Politie bieden onvoldoende ondersteuning in het herstel- en re-integratieproces van politiemedewerkers. Zowel voor de politiemedewerkers als voor de organisatie. Politiemedewerkers worden buitengesloten, waardoor zij eigen regie verliezen. Begeleiders kunnen de voortgang van de medewerkers niet goed monitoren. Management beschikt niet over de mogelijkheid trends te signaleren

Bekijk vacature »

Hans -

Hans -

29/10/2015 13:57:53
Quote Anchor link
Ik loop tegen het volgende probleem aan bij het installeren van de SonataBlockBundle als ik deze command ingeef: php composer.phar require sonata-project/block-bundle

Het volgende spuugt hij dan uit, en kan over de blockbundle weinig vinden helaas. Iemand?

Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
Using version ^2.3 for sonata-project/block-bundle
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - sonata-project/admin-bundle 2.3.6 requires sonata-project/block-bundle ~2.
2,>=2.2.7,<2.3 -> no matching package found.
    - sonata-project/admin-bundle 2.3.6 requires sonata-project/block-bundle ~2.
2,>=2.2.7,<2.3 -> no matching package found.
    - sonata-project/admin-bundle 2.3.6 requires sonata-project/block-bundle ~2.
2,>=2.2.7,<2.3 -> no matching package found.
    - Installation request for sonata-project/admin-bundle == 2.3.6.0 -> satisfi
able by sonata-project/admin-bundle[2.3.6].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your min
imum-stability setting
   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> f
or more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further commo
n problems.

Installation failed, reverting ./composer.json to its original content.


Toevoeging op 29/10/2015 14:40:16:

Dit heb ik overigens bij meerdere bundles kom ik nu achter, bijv de SonataSEObundle

Toevoeging op 29/10/2015 15:22:25:

En dit is overigens ook een melding die ik nu krijg als ik de SonataPageBundle wil installeren:

There is no extension able to load the configuration for "symfony_cmf_routing_extra" (in WEBSITEMAP\app/config\config.yml). Looked for namespace "symfony_cmf_routing_extra", found "framework", "security", "twig", "monolog", "swiftmailer", "assetic", "doctrine", "sensio_framework_extra", "wmc_page", "sonata_core", "sonata_block", "knp_menu", "sonata_doctrine_orm_admin", "sonata_admin", "sonata_page", "sonata_cache", "debug", "web_profiler", "sensio_distribution" in WEBSITEMAP\app/config\config.yml (which is being imported from "WEBSITEMAP\app/config/config_dev.yml").
 
PHP hulp

PHP hulp

13/06/2024 21:59:08
 
Frank Nietbelangrijk

Frank Nietbelangrijk

29/10/2015 18:52:05
Quote Anchor link
- Heb je al eens composer update geprobeerd?

Hier even mijn json require-gedeelte, Zou je even kunnen kijken of het overeenkomt.. Bij mij werkt dit prima iig.
Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
    "require": {
        "php": ">=5.3.9",
        "symfony/symfony": "2.7.*",
        "doctrine/orm": "~2.2,>=2.2.3,<2.5",
        "doctrine/dbal": "<2.5",
        "doctrine/doctrine-bundle": "~1.4",
        "symfony/assetic-bundle": "~2.3",
        "symfony/swiftmailer-bundle": "~2.3",
        "symfony/monolog-bundle": "~2.4",
        "sensio/distribution-bundle": "~4.0",
        "sensio/framework-extra-bundle": "~3.0,>=3.0.2",
        "incenteev/composer-parameter-handler": "~2.0",
        "friendsofsymfony/user-bundle": "~2.0@dev",
        "sonata-project/admin-bundle": "^2.3",
        "sonata-project/doctrine-orm-admin-bundle": "^2.3",
        "coresphere/console-bundle": "^0.3.1",
    "fbeen/uniqueslugbundle": "dev-master",
        "craue/formflow-bundle": "~3.0@dev",
        "knplabs/knp-paginator-bundle": "^2.5",
        "egeloen/ckeditor-bundle": "^3.0",
        "helios-ag/fm-bbcode-bundle": "^6.8",
        "hwi/oauth-bundle": "^0.3.9",
        "patchwork/jsqueeze": "~2.0",
        "leafo/scssphp": "0.3.3"
    },
 
Hans -

Hans -

30/10/2015 09:28:07
Quote Anchor link
Onderstaand de mijne, ik zie wel enig verschil tussen bijvoorbeeld de doctrine orm versie. Kan dit het probleem zijn? Ik weet overigens ook niet goed wat het onderstaande uberhaupt is.

Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
"require": {
        "php": ">=5.3.9",
        "symfony/symfony": "2.7.*",
        "doctrine/orm": "^2.4.8",
        "doctrine/doctrine-bundle": "~1.4",
        "symfony/assetic-bundle": "~2.3",
        "symfony/swiftmailer-bundle": "~2.3",
        "symfony/monolog-bundle": "~2.4",
        "sensio/distribution-bundle": "~4.0",
        "sensio/framework-extra-bundle": "^3.0.2",
        "incenteev/composer-parameter-handler": "~2.0",
        "knplabs/knp-menu-bundle": "~2",
        "sonata-project/page-bundle": "^2.3",
        "sonata-project/doctrine-orm-admin-bundle": "^2.3",
        "sonata-project/admin-bundle": "2.3.*",
        "sonata-project/translation-bundle": "^1.0",
        "sonata-project/cache-bundle": "^2.2",
        "sonata-project/easy-extends-bundle": "^2.1"
    },


Toevoeging op 30/10/2015 11:48:53:

BTW, als ik php composer.phar update uitvoer krijg ik de volgende melding:

Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
WEBSITENAAM>php composer.phar update
Loading composer repositories with package information
Updating dependencies (including require-dev)
  - Removing whiteoctober/breadcrumbs-bundle (1.2.0)
  - Removing twig/twig (v1.22.3)
  - Installing twig/twig (v1.23.0)
    Downloading: 100%

Writing lock file
Generating autoload files
> Incenteev\ParameterHandler\ScriptHandler::buildParameters
Updating the "app/config/parameters.yml" file
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache



  [Symfony\Component\Config\Exception\FileLoaderLoadException]
  There is no extension able to load the configuration for "symfony_cmf_routi
  ng_extra" (in WEBSITENAAM\app/config\config.yml). Looked for na
  mespace "symfony_cmf_routing_extra", found "framework", "security", "twig",
   "monolog", "swiftmailer", "assetic", "doctrine", "sensio_framework_extra",
   "wmc_page", "sonata_core", "sonata_block", "knp_menu", "sonata_doctrine_or
  m_admin", "sonata_admin", "sonata_page", "sonata_cache", "debug", "web_prof
  iler", "sensio_distribution" in WEBSITENAAM\app/config\config.y
  ml (which is being imported from "WEBSITENAAM\app/config/config
  _dev.yml").






  [Symfony\Component\DependencyInjection\Exception\InvalidArgumentException]
  There is no extension able to load the configuration for "symfony_cmf_routi
  ng_extra" (in WEBSITENAAM\app/config\config.yml). Looked for na
  mespace "symfony_cmf_routing_extra", found "framework", "security", "twig",
   "monolog", "swiftmailer", "assetic", "doctrine", "sensio_framework_extra",
   "wmc_page", "sonata_core", "sonata_block", "knp_menu", "sonata_doctrine_or
  m_admin", "sonata_admin", "sonata_page", "sonata_cache", "debug", "web_prof
  iler", "sensio_distribution"



Script Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache handl
ing the post-update-cmd event terminated with an exception



  [RuntimeException]
  An error occurred when executing the ""cache:clear --no-warmup"" command.



update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock]
 [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-
progress] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader]
 [-a|--classmap-authoritative] [--ignore-platform-reqs] [--prefer-stable] [--pre
fer-lowest] [packages1] ... [packagesN]
 
Hans -

Hans -

01/11/2015 01:07:26
Quote Anchor link
Iemand die me vooruit kan helpen?
 
Hans -

Hans -

02/11/2015 09:53:45
Quote Anchor link
Alsjeblieft?
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.