Automatisch logout na half uur

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Meddiecap B

Meddiecap B

15/01/2010 13:52:00
Quote Anchor link
Hoi,

Ik heb een probleem met de sessie tijd.

Ik heb de session.gc_maxlifetime op 20 uur staan en de session.cookie_lifetime op 0. Toch wordt er telkens na een half uur ongeveer uitgelogd.

In de phpinfo() staan de instellingen juist weergeven; session.gc_maxlifetime op 20 uur, session.cookie_lifetime op 0.

Is er nog iets wat er fout kan zijn?
 
PHP hulp

PHP hulp

03/12/2020 23:50:11
 
TJVB tvb

TJVB tvb

15/01/2010 13:59:00
Quote Anchor link
Zit er niet toevallig ergens in je code een check die een tijd bijhoudt en na 30 minuten uitlogt?
Gewijzigd op 01/01/1970 01:00:00 door TJVB tvb
 
Meddiecap B

Meddiecap B

15/01/2010 14:12:00
Quote Anchor link
neen
 
- SanThe -

- SanThe -

15/01/2010 14:33:00
 
Meddiecap B

Meddiecap B

15/01/2010 14:41:00
Quote Anchor link
Maar dat werkt niet als je heel lang moet doen over het invullen van een formulier (toch?). Wat bij mij het geval is.
 
- SanThe -

- SanThe -

15/01/2010 14:46:00
Quote Anchor link
Sorry, ik had de vraag niet goed gelezen. Jouw inlogtijd is niet te lang maar te kort als ik het nu goed begrijp.
 
Meddiecap B

Meddiecap B

15/01/2010 14:49:00
Quote Anchor link
Juist, maar hoewel ik het op 20 uur heb ingesteld (voor zover ik weet)

session.gc_maxlifetime 72000
session.cookie_lifetime 0

..wordt er toch na ong. een half uur uitgelogd.

Misschien niet overbodig om te vermelden:
session.gc_divisor 1000
session.gc_probability 1
 
Joren de Wit

Joren de Wit

15/01/2010 14:58:00
Quote Anchor link
En als je session.cookie_lifetime nu ook eens een waarde geeft?

ps. Je start de server wel iedere keer opnieuw nadat je een instelling gewijzigd hebt?
Gewijzigd op 01/01/1970 01:00:00 door Joren de Wit
 
Meddiecap B

Meddiecap B

15/01/2010 15:00:00
Quote Anchor link
Kan ik doen, maar als hij op 0 staat wil dat zeggen (tenzij ik mij vergis) dat de sessie duurt tot de browser wordt afgesloten.
 
Joren de Wit

Joren de Wit

15/01/2010 15:13:00
Quote Anchor link
Dat klopt, dat zou de normale werking zijn. Maar aangezien het niet werkt, zou je e.e.a. eens kunnen proberen te wijzigen ;-)

Je hebt de server ook elke keer gerestart na het wijzigen van je php.ini?
 
Meddiecap B

Meddiecap B

15/01/2010 15:58:00
Quote Anchor link
Ik heb ook gerestart.

Maar het komt erop neer dat het niet aan de instellingen ligt?

In dat geval zal ik de oorzaak ergens anders moeten zoeken.
 
Joren de Wit

Joren de Wit

15/01/2010 16:18:00
Quote Anchor link
Voer je toevallig elke keer dezelfde handeling uit of bezoek je toevallig steeds dezelfde pagina op het moment dat je uitgelogd wordt? Dan zou je daar eens moeten beginnen...
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.