CSS Pseudo (:before & :after) hover transitions

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Eschwin Moerkerken

Eschwin Moerkerken

15/09/2015 16:08:49
Quote Anchor link
Goedenmiddag,

Sinds ik ben geupgrade naar windows 10 (en waarschijnlijk mijn chrome automatisch geüpdatet is van 44 naar 45.0.2454.85m) werken de transitions niet meer op mijn :before en :after elementen wanneer ik hier overheen hover.

In firefox, safari, opera en andere browsers (zowel desktop, tablet als mobiel) werken deze nog wel allemaal.
Over dit probleem kan ik dan ook verder op het internet niks vinden zo snel dat ik er even naar heb gezocht.

Hebben nog meer mensen hier last van of weet iemand een 'workaround' voor deze 'bug'? Als dit al een bug te noemen is.
 
PHP hulp

PHP hulp

19/01/2022 07:56:40
 
Daan Slagter

Daan Slagter

15/09/2015 19:45:12
Quote Anchor link
Het zou wel gewoon moeten werken volgens: http://caniuse.com/#search=%3Abefore
Gewijzigd op 15/09/2015 19:45:24 door Daan Slagter
 
Johan K

Johan K

15/09/2015 23:10:42
Quote Anchor link
Zonder een sample code valt er weinig over te zeggen, behalve dat je misschien de "-webkit-" prefix weg kunt halen? Misschien heb je wel je CSS transform eerst en later de -webkit- prefix gebruikt?

Zelf gebruik ik ook transform, en nog geen problemen gehad (al dat ik het alleen in ff en chrome kan testen)
Gewijzigd op 15/09/2015 23:13:09 door Johan K
 
Eschwin Moerkerken

Eschwin Moerkerken

16/09/2015 09:01:11
Quote Anchor link
Voorbeeld

Mijn voorbeeld werkt vreemd genoeg wel in jsbin. Vreemd genoeg heb ik hem exact hetzelfde in mijn website en werkt hij van de ene op de andere dag niet meer.

Toevoeging op 16/09/2015 09:18:35:

Heb de 'bug' al gevonden. Kennelijk moet een anchor in een table een display:block; of display:inline-block; hebben voordat deze een pseudo element transition kan hebben.

Bedankt voor het meedenken! Mocht nog iemand op dit probleem stuiten, check dan áltijd even of je parent wel een position:relative; heeft als je pseudo een position:absolute; heeft en probeer wat met display te spelen!

Kennelijk had ik wat veranderd in mijn CSS na het overstappen op windows 10 of updaten van google chrome waardoor ik dacht dat dit de fout veroorzaakte (aangezien het in andere browsers wel prima werkte).
Gewijzigd op 16/09/2015 09:01:47 door Eschwin Moerkerken
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.