Link werkt niet in Internet Explorer!

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Mike van den Berg

Mike van den Berg

08/05/2008 11:05:00
Quote Anchor link
Beste PHP'ers,
Ik ben druk bezig met het maken van een website voor een Guild (WoW)
Wat me nu gebeurd:

Gebruik CSS voor de stijl, en HTML pagina's om te testen op mijn werk(ik heb hier geen beschikking over een dusdanige internetverbinding zonder blokkades!)

Wanneer ik de site bekijk in Internet explorer, doen sommige links wel wat ik wil, sommige niet, 3 doen aan de opgedragen hover, de rest niet, haal de hover weg denk je dan, maar de rest van de links werkt niet.

dit heb ik staan, maar daarvan doen slechts de bovenste links het!

Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
<div class="navigatie">
    <ul>
    <h2>Navigation Menu</h2>
    <li><a class="navigatie" href="http://firgurth.nl/Praetorian/index.html" title="Praetorian - Home">Home</a></li>
    <li><a class="navigatie" href="http://firgurth.nl/Praetorian/news.html" title="Praetorian - News">News</a></li>
    <li><a class="navigatie" href="http://firgurth.nl/Praetorian/guild.html" title="Praetorian - The Guild">The Guild</a></li>
    <li><a class="navigatie" href="http://firgurth.nl/Praetorian/members.html" title="Praetorian - Members'">Members</a></li>
    <li><a class="navigatie" href="http://firgurth.nl/Praetorian/calendar.html" title="Praetorian - Calendar">Calendar</a></li>
    <li><a class="navigatie" href="http://firgurth.nl/Praetorian/forums.html" title="Praetorian - Forums">Forums</a></li>
    <li><a class="navigatie" href="http://firgurth.nl/Praetorian/guides.html" title="Praetorian - Guides">Guides</a></li>
    <li><a class="navigatie" href="http://firgurth.nl/Praetorian/links.html" title="Praetorian - Links">Links</a></li><br />
    <h2>Members</h2>
    <li><a class="navigatie" href="http://firgurth.nl/Praetorian/login.html" title="Praetorian - Login">Login</a></li>
    <li><a class="navigatie" href="http://firgurth.nl/Praetorian/register.html" title="Praetorian - Register">Register</a></li>
    </ul>
</div>  


de link is volluit, omdat Internet Explorer mijn php code niet pakt, firefox doet dit echter wel, alleen heb ik dan weer een groot probleem in mijn css!

de links in de div, worden margin:-40px geplaatst, terwijl de css margin:0px aangeeft,
heeft iemand een oplossing voor mijn probleem,

ik zou graag ook horen hoe ik dat hoerige probleem met css in firefox en ie kan oplossen,

alvast bedankt!
Mike
Gewijzigd op 01/01/1970 01:00:00 door Mike van den Berg
 
PHP hulp

PHP hulp

02/12/2020 18:15:18
 
- SanThe -

- SanThe -

08/05/2008 11:16:00
Quote Anchor link
Pas je script even aan en gebruik en tags om je code heen. Gebruik je http://www.phphulp.nl/imgs/forum/edit.gif knop om dit te doen.

SanThe.
 
Jesper Diovo

Jesper Diovo

08/05/2008 11:23:00
Quote Anchor link
Welke versie van IE gebruik je?
 
Mike van den Berg

Mike van den Berg

08/05/2008 11:32:00
Quote Anchor link
Version: 6.0.2900.2180
bij deze versie werken de links niet,

Version: 7.0
Bij deze is mijn content div, totaal verplaatst,

Firefox:
hier wordt mijn hele stylesheet uit zichzelf aangepast
 
Jelmer -

Jelmer -

08/05/2008 11:37:00
Quote Anchor link
Wanneer je je pagina laadt zonder CSS stylesheet erin werkt wel alles gewoon? Zo ja, dan is het waarschijnlijk dat er een laag over je links schuift, waardoor de links als het ware onder een doorzichtige div terechtkomen. En aangezien je dan niet meer over de links maar over de div gaat met de muis, kan je er niet meer op klikken en werkt :hover niet.

Plaats anders ook even een link naar je HTML + CSS zodat we zelf even kunnen prutsen met Firebug e.a. om te kijken waar het aan ligt.
 
Mike van den Berg

Mike van den Berg

08/05/2008 11:49:00
Quote Anchor link
Internet Explorer 6.0:
http://firgurth.nl/Praetorian/

De links werken niet,


Firefox:
http://firgurth.nl/Praetorian/

Divs hebben een andere plaats!


Stylesheet:
http://firgurth.nl/Praetorian/stylesheet.css


Gelieve niet te kijken naar de netheid van de CSS want die is er niet,
 

08/05/2008 13:58:00
Quote Anchor link
Haal de H2 koppen weg uit je UL. Als je er een kop tussen wil zetten moet je eerst de UL beëindigen en daarna weer opnieuw en UL starten. Waarschijnlijk zitten die H2 tags midden in een list een beetje dwars :)

Daarnaast hoef je de LI geen class mee te geven! Je hebt ze sowieso dezelfde class gegeven als de DIV, dus dan gaat er vanzelf iets mis. Geef de LI geen stijl mee en bouw je CSS als volgt op

Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
#navigatie
{
 opbouw van je div
}
#navigatie ul
{
 stijl van je ul in de navigatie div
}
#navigatie li a
{
  stijl van je links en li's in de navigatie div
}
#navigatie li a:hover
{
  stijl van je links en li's (hover) in de navigatie div
}



Ik zal een klein voorbeeld geven:

Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#navigatie
{
 float: left;
 width: 500px;
 border: 1px solid #000000;
 background: #FFFFFF;
 padding: 10px;
}
#navigatie ul
{
 margin: 0px;
 list-style-type: none;
 padding: 0px;
}
#navigatie li a
{
  display: block;
  width: 300px;
  height: 100px;
  background: #FF9900;
  color: #000000;
  text-decoration: none;
  font-weight: bold;
  margin-bottom: 5px;
}
#navigatie li a:hover
{
  display: block;
  width: 300px;
  height: 100px;
  background: #FFFFFF;
  color: #000000;
  text-decoration: underline;
  font-weight: bold;
  margin-bottom: 5px;
}
Gewijzigd op 01/01/1970 01:00:00 door
 
Mike van den Berg

Mike van den Berg

08/05/2008 14:01:00
Quote Anchor link
Dank! ik ga het proberen...


...Nee, heeft niet gewerkt.

nog andere opties/ mogelijkheden?

Nope nog niet,
wanneer ik het volledig kopieer en uiteraard de Id= toepas, werkt het nogsteeds niet
de eerste 2 links werken, incl de :hover, de rest werkt niet,
hij ziet gewoon geen link ofzo,


Ook heel raar:
Als ik de wel werkende link kopieer, en letterlijk eronder plak, pakt IE nogsteeds de link niet, hij ziet het niet als een link, :hover weergeeft geen handje, geen link,
erg raar!

Ondersteund Firefox a:hover?
Gewijzigd op 01/01/1970 01:00:00 door Mike van den Berg
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.