Symfony 2 Gratis ?

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Paco de Wulp

Paco de Wulp

07/09/2016 22:02:12
Quote Anchor link
Is Symfony gratis of moet ervoor worden betaald ?
Waar kan ik het downloaden ?
Gewijzigd op 07/09/2016 22:03:46 door Paco de Wulp
 
PHP hulp

PHP hulp

16/08/2018 18:22:38
 
- Ariën -
Beheerder

- Ariën -

07/09/2016 22:16:06
Quote Anchor link
Met alleen 'Symfony' in Google had ik al een hit op de tweede item:
https://symfony.com/ ;-)

Maar waarom niet gewoon 3.1 gebruiken? Die is behoorlijk vernieuwd en zal nog een hoop updates krijgen.
Gewijzigd op 07/09/2016 22:18:11 door - Ariën -
 
Paco de Wulp

Paco de Wulp

07/09/2016 22:28:57
Quote Anchor link
Dus het is gratis ? opensource ?)
 
Ben van Velzen

Ben van Velzen

07/09/2016 22:32:04
Quote Anchor link
Uiteraard, gewoon te installeren via composer, of pullen vanaf github.
 
Paco de Wulp

Paco de Wulp

07/09/2016 22:38:36
Quote Anchor link
Geweldig! Dat wilde ik even weten. Dank jullie we !
 
Frank Nietbelangrijk

Frank Nietbelangrijk

08/09/2016 00:04:44
Quote Anchor link
Symfony is gratis inderdaad en wordt in de praktijk door een community van PHP programmeurs onderhouden. Het is echt een fantastisch PHP framework waarmee je zeer professionele websites kunt bouwen. Hierbij hoef je niet telkens het wiel zelf uit te vinden want je kunt allerlei (tevens gratis) modules* toevoegen aan je framework. De tol die je betaald is dat het tijd kost om te leren over de talloze mogelijkheden die het framework biedt maar dat is een hobbel die je zeker zou moeten willen nemen. Voor als je net begint zijn er ook best goede video tutorials. Verder moet je veel Googlen en lezen.

* deze heten eigenlijk bundles.
 
Willem vp

Willem vp

09/09/2016 00:13:03
Quote Anchor link
- Ariën - op 07/09/2016 22:16:06:
Maar waarom niet gewoon 3.1 gebruiken?

Een reden daarvoor zou kunnen zijn dat 2.7 en 2.8 LTS-versies zijn en dus langer gesupport worden dan 3.0 en 3.1...
 
- Ariën -
Beheerder

- Ariën -

09/09/2016 00:29:21
Quote Anchor link
Maar zou het niet zo zijn dat er misschien nog een 3.2 uitkomt waar je redelijk makkelijk naar kan updaten, die dan ook weer lang supported is? De overstap van 2.7/2.8 naar 3.0 kent wel wat wijzigingen, heb ik gehoord.
 
Frank Nietbelangrijk

Frank Nietbelangrijk

09/09/2016 08:35:52
Quote Anchor link
Uiteraard zijn er een aantal veranderingen maar de enigste 'alledaagse' verandering die ik ben tegengekomen is dat fomulier-veld-types nu niet meer met een naam in de vorm van een string worden gedeclareerd maar met de "fully-qualified class name"

2.8:
Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
<?php
$form
= $this->createFormBuilder()
   ->
add('name', 'text')
   ->
add('age', 'integer')
   ->
getForm();
?>


3.x:
Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
7
8
9
<?php
use Symfony\Component\Form\Extension\Core\Type\IntegerType;
use Symfony\Component\Form\Extension\Core\Type\TextType;

$form = $this->createFormBuilder()
   ->
add('name', TextType::class)
   ->
add('age', IntegerType::class)
   ->
getForm();
?>


De hele lijst met veranderingen kun je hier vinden.
Gewijzigd op 09/09/2016 08:36:15 door Frank Nietbelangrijk
 
Willem vp

Willem vp

09/09/2016 10:22:54
Quote Anchor link
- Ariën - op 09/09/2016 00:29:21:
Maar zou het niet zo zijn dat er misschien nog een 3.2 uitkomt waar je redelijk makkelijk naar kan updaten, die dan ook weer lang supported is?

Nope. 3.2 en 3.3 hebben elk een supportduur van 8 maanden. Pas versie 3.4 is weer een LTS-release (3 jaar gesupport), maar die komt pas november volgend jaar uit.
Gewijzigd op 09/09/2016 10:26:24 door Willem vp
 
Paco de Wulp

Paco de Wulp

09/10/2016 23:27:08
Quote Anchor link
Ik krijg de volgende foutmelding bij het runnen van de installer:(# php symfony new TEST)

[GuzzleHttp\Exception\RequestException]
cURL error 60: SSL certificate problem: unable to get local issuer certificate

[GuzzleHttp\Ring\Exception\RingException]
cURL error 60: SSL certificate problem: unable to get local issuer certificate

Iemand enig idee waar aan dit kan liggen ?
(Symfony 2.8)
Gewijzigd op 09/10/2016 23:28:10 door Paco de Wulp
 
Frank Nietbelangrijk

Frank Nietbelangrijk

09/10/2016 23:33:03
Quote Anchor link
Hier net nog getest en bij werkt het nog altijd prima.

Misschien moet je de installer even vervangen...
 
Paco de Wulp

Paco de Wulp

09/10/2016 23:41:59
Quote Anchor link
Installer vervangen....geen ander resultaat
 
- Ariën -
Beheerder

- Ariën -

09/10/2016 23:46:01
Quote Anchor link
Volgens Google lijkt het dat je een certificaat mist:

https://www.google.nl/search?q=cURL+error+60%3A+SSL+certificate+problem%3A+unable+to+get+local+issuer+certificate
Gewijzigd op 09/10/2016 23:46:11 door - Ariën -
 
Ben van Velzen

Ben van Velzen

10/10/2016 00:06:19
Quote Anchor link
Normaliter gewoon een kwestie van apt-get install ca-certificates.
 
Wouter J

Wouter J

10/10/2016 00:26:37
Quote Anchor link
Quote:
Nope. 3.2 en 3.3 hebben elk een supportduur van 8 maanden. Pas versie 3.4 is weer een LTS-release (3 jaar gesupport), maar die komt pas november volgend jaar uit.

Maar aangezien alle minor releases backwards compatible met elkaar zijn kun je zonder problemen 3.0 (of 3.1, 3.2, 3.3) upgraden naar 3.4. Dus gewoon altijd de meest recente versie pakken zou ik aanraden. (zie ook https://stovepipe.systems/post/symfony-versioning-and-compatibility )
 
Paco de Wulp

Paco de Wulp

10/10/2016 00:30:35
Quote Anchor link
cacert.pem gedownload

php.ini aangepast --> curl.cainfo = "C:\XAMPP\php\extras\ssl\cacert.pem"

en het werkt !

Wat een gedoe zeg ....pfff
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.