Unable to load dynamic lib, pgsql

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

coördinator kantoorautomatisering (32-36 uur

Breng jij onze kantoorautomatisering naar een hoger (online) plan? Jouw uitdaging De NTS heeft ruim 100 medewerkers. Om onze mensen hun werk te laten doen hebben ze een goed werkende werkplek nodig. Dat bestaat uit hardware: zoals pc, laptop, telefoon, tablet, software zoals Office365 suite en aanvullende bedrijfsapplicaties en een netwerk. We zijn druk bezig met het vernieuwen van onze kantoorautomatisering; we willen onze medewerkers overal, altijd op elk device kunnen laten samenwerken. Om hierin de regie te kunnen nemen zoeken we jou als coördinator kantoorautomatisering! De kantoorautomatiseringsondersteuning werd in het verleden door een Shared Service geleverd. Het Shared Service wordt opgeheven en de

Bekijk vacature »

Storeman storeman

storeman storeman

15/05/2008 15:31:00
Quote Anchor link
Ik krijg onderstaande foutmelding in mijn logfiles:

[15-May-2008 15:23:15] PHP Warning: PHP Startup: Unable to load dynamic library 'd:/wamp/bin/php/php5.2.6/ext/php_pdo_pgsql.dll' - The specified module could not be found.
in Unknown on line 0

Ik heb zojuist geupgrade vanaf 5.2.5 naar 5.2.6, hiervoor heeft het prima gewerkt maar nu doet hij het niet meer, alle ander extensies worden wel goed geladen en geven geen fouten. Ook staat het bestand gewoon op de gegeven locatie.

Ligt dit aan versie 5.2.6 of zie ik iets stoms over het hoofd?
Gewijzigd op 01/01/1970 01:00:00 door Storeman storeman
 
PHP hulp

PHP hulp

25/09/2020 15:41:38
 
- SanThe -

- SanThe -

15/05/2008 15:58:00
Quote Anchor link
module could not be found

Lijkt mij duidelijk.
 
Thomas van Broekhoven

Thomas van Broekhoven

15/05/2008 17:06:00
Quote Anchor link
Ga even naar je IIS (Internet Information Service) op je computer, ook te vinden bij configuratiescherm -> Systeembeheer. Daar kan je alle extensies zien en wat er fout is gegaan. Zelf denk ik dat je het bestand niet in de goede map hebt geplaatst!
 

15/05/2008 19:07:00
Quote Anchor link
Thomas schreef op 15.05.2008 17:06:
Ga even naar je IIS (Internet Information Service)

Ik vind het knap dat jij wamp aan kan zien voor IIS.... Dat blabla'tje (no offence, stopwoord) van jou heeft er dus niks mee te maken :-).
 
Thomas van Broekhoven

Thomas van Broekhoven

15/05/2008 19:17:00
Quote Anchor link
Ik weet niet wat je zegt Karl, maar het zal allemaal wel. Ik deed het op deze manier en aangezien een forum is om elkaar te helpen doe ik dat, of het het juiste antwoord is is punt 2! Kan je wel moeilijk gaan doen door mijn woorden af te kraken maar heb je zelf een alternatief? Zo ja, meld dat dat gewoon en blijf ontopic!
 
Jesper Diovo

Jesper Diovo

15/05/2008 19:21:00
Quote Anchor link
Je script gebruikt waarschijnlijk PDO met driver pgSQL. Die pgSQL driver zal niet bij je extensies zitten/niet geïnstalleerd zijn.
 

15/05/2008 19:54:00
Quote Anchor link
Thomas schreef op 15.05.2008 19:17:
Ik weet niet wat je zegt Karl, maar het zal allemaal wel.

Ah, jah, het zal allemaal wel.... Kijk eens naar: IIS en wamp want:
storeman schreef op 15.05.2008 15:31:
Unable to load dynamic library 'd:/wamp/bin/php/php5.2.6/ext/php_pdo_pgsql.dll'

Dat bedoel ik met:
Karl schreef op 15.05.2008 19:07:
Ik vind het knap dat jij wamp aan kan zien voor IIS....


Thomas schreef op 15.05.2008 19:17:
Ik deed het op deze manier

Dat zal best, maar hier helpt het dus niet, hij heeft een hele andere server. Jij maakt gebruik van een server die bij windows xp pro zit, niet eens bij home (ik heb hem dus niet, hoe het met vista zit weet ik niet).

Thomas schreef op 15.05.2008 19:17:
en aangezien een forum is om elkaar te helpen doe ik dat, of het het juiste antwoord is is punt 2!

Aan dat antwoord van jou heeft ie dus niks.... Dus punt twee vervalt.

Thomas schreef op 15.05.2008 19:17:
Kan je wel moeilijk gaan doen door mijn woorden af te kraken maar heb je zelf een alternatief? Zo ja, meld dat dat gewoon en blijf ontopic!

Ik doe niet moeilijk, ik vind alleen dat ie geen rare dingen hoeft uit te spoken, weet ik veel straks haalt ie het in z'n hoofd om IIS te gaan instaleren terwijl dat helemaal niet nodig is. Ik kraak je ook niet af, ik zeg alleen dat ik niet snap dat je wat verteld over een hele andere server, waardoor je post dus waardeloos wordt.

Bovendien heeft SanThe zo ongeveer al het antwoord gegeven....
Gewijzigd op 01/01/1970 01:00:00 door
 
Thomas van Broekhoven

Thomas van Broekhoven

15/05/2008 20:26:00
Quote Anchor link
@ Karl
Ik heb Vista, en ja ik moest ISS installeren, maar voor mij was dit de reden dat die het niet deed. Daarom dacht ik: Hij heeft hetzelfde probleem, wat achteraf misschien verkeerd begrepen is van mij, dus laat ik hem dit advies geven. Sorry voor het verkeerde advies dan maar het was goed bedoeld ;)
 
Storeman storeman

storeman storeman

16/05/2008 09:57:00
Quote Anchor link
Okee, ik hoop dat het weer recht zit tussen jullie ;).

De extensie staat gewoon in de aangegeven map, als ik dat exacte adres kopieer naar de verkenner, wil ie gewoon het bestand openen.

Daarnaast worden alle andere extensies wel geladen, dus vandaar dat ik dit vreemd vind. Ik heb nu weer een oudere versie van php in gebruik en de pdo_pgsql extensie werkt wel weer. Vreemd, het kan aan de dll liggen of aan php...
 
Storeman storeman

storeman storeman

16/05/2008 13:50:00
Quote Anchor link
Het is opgelost, ik heb de dll uit de ext-map van 5.2.5 gepakt en deze in de ext-map van 5.2.6 geplaatst, nu draait ie gewoon.

Apart
 
Storeman storeman

storeman storeman

22/02/2009 09:18:00
Quote Anchor link
Ik kick dit topic maar even, omdat ik nog eens in dit probleem ben gedoken. Bij een update naar een nieuwere php versie kom ik het steeds weer tegen. Het leek mij sterk dat hier nooit wat aan was gedaan door het php-team.

Ik kwam de volgende bug-tracker tegen: http://bugs.php.net/bug.php?id=47026

Vanaf PHP5.2.6 wordt de pdo driver ondersteund door de libpq.dll. Deze zou dynamisch geladen moeten worden. Daar gaat het kennelijk fout (unable to load dynamic library).

De libpq.dll staat in de root van mijn php directory (waar ook php.exe staat). Alleen heb ik nog geen idee hoe het komt dat deze niet geladen wordt. Aangezien ik het vreemd vind dat ik bestanden zou moeten verplaatsen in de php-directory.
 
Jelmer -

Jelmer -

22/02/2009 09:57:00
Quote Anchor link
Waar staan je andere dynamic libraries van PHP? Ik weet niet precies waar Windows allemaal zoekt naar dlletjes, maar ik heb wel verhalen gehoord dat je ze in \Windows\System32 moet zetten.

Misschien dat phpinfo() aangeeft waar je moet wezen. Onder Linux/Mac staat het pad bij extension_dir.
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.