web.config IIS & naar amp;

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Daniel van Seggelen

Daniel van Seggelen

14/02/2021 05:40:22
Quote Anchor link
De titel zegt het al,

Voor een joomla site, bij tags, word een link als dit gemaakt:

https://www.domain.nl/+Computers+.html?Internet=

Kan ik dit in web.config redirecten naar:

https://www.domain.nl/+Computers+&+Internet.html

Want dat werkt het zoals het hoort.

groet

Daniel.
 
PHP hulp

PHP hulp

19/10/2021 13:56:25
 
- Ariën -
Beheerder

- Ariën -

14/02/2021 09:58:02
Quote Anchor link
Waarom niet iets als https://www.domain.nl/tags/computers
En in plaats van & een - ?

Dat is veel duidelijker.
Gewijzigd op 14/02/2021 10:25:31 door - Ariën -
 
Daniel van Seggelen

Daniel van Seggelen

14/02/2021 10:46:17
Quote Anchor link
Ja ok, dat is ook prima, maar hoe maak ik een dergelijk redirect?

Quote:
Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
<?xml version="1.0" encoding="UTF-8"?>

<configuration>
<location path=".">
<system.webServer>

<security>
<requestFiltering allowDoubleEscaping="true"/>
</security>

<directoryBrowse enabled="false" />
<rewrite>
<rules>
<rule name="Joomla! Rule 1" stopProcessing="true">
<match url="^(.*)$" ignoreCase="false" />
<conditions logicalGrouping="MatchAny">
<add input="{QUERY_STRING}" pattern="base64_encode[^(]*\([^)]*\)" ignoreCase="false" />
<add input="{QUERY_STRING}" pattern="(&gt;|%3C)([^s]*s)+cript.*(&lt;|%3E)" />
<add input="{QUERY_STRING}" pattern="GLOBALS(=|\[|\%[0-9A-Z]{0,2})" ignoreCase="false" />
<add input="{QUERY_STRING}" pattern="_REQUEST(=|\[|\%[0-9A-Z]{0,2})" ignoreCase="false" />
</conditions>
<action type="CustomResponse" url="index.php" statusCode="403" statusReason="Forbidden" statusDescription="Forbidden" />
</rule>
<rule name="Joomla! Rule 2">
<match url="(.*)" ignoreCase="false" />
<conditions logicalGrouping="MatchAll">
<add input="{URL}" pattern="^/index.php" ignoreCase="true" negate="true" />
<add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
</conditions>
<action type="Rewrite" url="index.php" />
</rule>
</rules>
</rewrite>
<httpProtocol>
<customHeaders>
<add name="X-Content-Type-Options" value="nosniff" />
</customHeaders>
</httpProtocol>
</system.webServer>
</location>
</configuration>
 
Rob Doemaarwat

Rob Doemaarwat

14/02/2021 17:29:08
Quote Anchor link
Ik heb het idee dat je probleem heel ergens anders ligt, en dat je nu aan symptoombestrijding aan het doen bent (en je zult vast je redenen hebben om met IIS te werken). Maarrr ... kun je niet gewoon bovenin de index.php (waar alle verkeer zo te zien naar toe wordt gestuurd) een stukje code toevoegen die (vermoedelijk) je $_SERVER['REQUEST_URI'] op de juiste manier "verherbouwt" voordat ie door de Joomla mangel gaat? (ook symptoombestrijding, maar in ieder geval een oplossing ;-) ).
 
- Ariën -
Beheerder

- Ariën -

14/02/2021 20:12:22
Quote Anchor link
Oef, index.php aanpassen van Joomla?
het is niet te hopen dat de index door een update-mechanisme wordt overschreven.

In de backend kan je blijkbaar het één en ander aanpassen aan slugs en rewrite-regels.
Ik hoop dat deze een detectie op Apache/IIS doet, want .htaccess gaat volgens mij op IIS niet werken. Misschien wel (beperkt) met een add-on?
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.