wie kan mijn cms upgraden van php 5.6 naar 7.1

Overzicht Reageren

Sponsored by: Vacatures door Monsterboard

Peter Koster

Peter Koster

04/03/2019 22:29:34
Quote Anchor link
Op verzoek van admin nieuwe post omdat de in ander draadje geopperde simpele oplossing niet echt goed schijnt te zijn. Wie zou mijn cms-script om kunnen zetten van php 5.6 naar php 7.1?
Ik heb een cms-script (lang geleden gebouwd door familielid dat niet meer in beeld is, zelf weet ik niets van php/programmeren). De content van mijn blog (teksten, verwijzingen naar foto's staan in een mysql-database, net als een hele verzameling links, waarvan delen op verschillende pagina 's aangeroepen worden. Verder zitten er opmaakblokken in die op alle pagina's hetzelfde zijn en zo maar één keer veranderd worden.
Op termijn wil ik mijn hele siteflink moderniseren, maar mijn provider gooit 5.6 al binnenkort van zijn server af (al heeft ie nog geen termijn gegeven).
Gewijzigd op 04/03/2019 22:31:03 door Peter Koster
 
PHP hulp

PHP hulp

23/11/2020 23:08:46
 
- Ariën -
Beheerder

- Ariën -

04/03/2019 22:34:27
Quote Anchor link
Je zou kunnen overwegen om een bestaand CMS zoals Wordpress of Joomla te kunnen gebruiken. Want als het best oud is, zullen de veranderingen niet enkel bij MySQL -> MySQLi blijven, en wordt het duur maatwerk. Ook phpBB 2 wordt allang niet meer ondersteund.
Gewijzigd op 04/03/2019 22:52:33 door - Ariën -
 
Thomas van den Heuvel

Thomas van den Heuvel

04/03/2019 23:29:33
Quote Anchor link
Oef.

Overlib en vraagteken wiebertjes in je tekst. Hoe oud is dat spul? :]
Gewijzigd op 04/03/2019 23:33:56 door Thomas van den Heuvel
 
- Ariën -
Beheerder

- Ariën -

04/03/2019 23:38:08
Quote Anchor link
Zo te lezen 'lang geleden gebouwd...'
 
Peter Koster

Peter Koster

06/03/2019 00:39:36
Quote Anchor link
Dat script is inderdaad oud (meer dan tien jaar), maar die wiebertjes vertoont ie pas na herstel van crash maandag. Dit weekeinde crashte de site plotseling: internal server error. Bleek dat provider automatisch ge-upgrade had naar 7.1. Helpdesk heeft voor 5.6 teruggezet, sindsdien die wiebertjes. Maar ook de aankondiging dat 5.6 niet lang meer ondersteund wordt...
Importeren in Wordpress lijkt me ideaal, maar 11.000 entries (inclusief reacties, exclusief links) met de hand overzetten lijkt me geen werkbaar plan...
 
- Ariën -
Beheerder

- Ariën -

06/03/2019 00:50:37
Quote Anchor link
Die wiebertjes (die naam onthoud ik) hebben te maken met verkeerd gebruik van UTF-8.
Heeft je hosting ook wat aan de database aangepast? Want eigenlijk zou dit niet zomaar mogen gebeuren?
Bij een migratie van PHP 5.x naar 7 heb ik nooit zulke fratsen gehad.

Verder zijn er met PHP wel mogelijkheden om 11.000 items over te zetten naar Wordpress via een conversiescriptje of een SQL-file die gemaakt moet worden. Of je kan het omzetten naar een CSV-bestand. Ik weet niet tot hoeverre Wordpress hier wat mee kan, of anderzijds is er een plug-in voor. Maar ik durf te wedden dat Wordpress op een manier hierin voorziet.
Gewijzigd op 06/03/2019 00:56:19 door - Ariën -
 
Thomas van den Heuvel

Thomas van den Heuvel

06/03/2019 01:06:06
Quote Anchor link
Waarschijnlijk zat de data al corrupt in de database en is het na de conversie/update compleet vernaggeld, mogelijk mede omdat de default encodering ergens onderweg is veranderd. Dit is dan ook iets wat je zult moeten repareren.

@Peter persoonlijke berichten al gecontroleerd? Zie linksboven op de pagina.

http://fangorn.thijma.nl/images/phphulp/persoonlijk-bericht.png
 
Ozzie PHP

Ozzie PHP

06/03/2019 01:09:39
Quote Anchor link
Peter Koster op 04/03/2019 22:29:34:
Op termijn wil ik mijn hele siteflink moderniseren ...

Ooooh, dit is gaaf zeg :-D

Kijk dan! Klik op die link en je ziet hoe websites er rond (wat zal het precies geweest zijn) het jaar 2000-2005 uitzagen. Hoe grappig! Pure nostalgie :-)
 
- Ariën -
Beheerder

- Ariën -

06/03/2019 01:15:42
Quote Anchor link
Zo kan ik nog wel wat sites die typisch 'Web 1.0' zijn ... :-P
Maar als je WordPress pakt, en een leuke template opzoekt, dan heb je in no-time al wat opgezet wat aan de eisen van deze tijd voldoet: makkelijk schaalbaar op smartphones en tablets, modern en geordende code wat voor een beetje snelheid zorgt.

Heb je alleen nog de content die je over moet pompen.
Gewijzigd op 06/03/2019 01:16:05 door - Ariën -
 
Ozzie PHP

Ozzie PHP

06/03/2019 01:19:13
Quote Anchor link
>> Zo kan ik nog wel wat sites die typisch 'Web 1.0' zijn ... :-P

Hmmm, ik vraag me af of mijn vermoeden waaraan jij denkt juist is haha ...
 



Overzicht Reageren

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.