jQuery stopt IE support in v2.0

Toegevoegd door Wouter J, 10 jaar geleden

jQuery stopt IE support in v2.0Het jQuery team heeft na veel overleg besloten de support voor oudere IE versies te stoppen. Ze gaan zich nu alleen nog maar richten op de moderne browsers, dat hebben ze bekend gemaakt tijdens de jQuery conference, deze week.

jQuery heeft dit besluit genomen omdat het volgens hun de bestandsgrootte van jQuery drastisch zou verkleinen. Ook beweren ze betere functies te kunnen schrijven, minder problemen zullen krijgen en betere error handling kunnen toevoegen.

Aangezien ze zelf ook wel door hebben dat 60% van de wereld nog IE8 of lager gebruikt en ze als gedachte 'support voor elke browser' hebben, heeft het jQuery team besloten dubbel zo hard te gaan werken. In plaats van 1 bestand, jQuery 2.0, gaan ze namelijk 2 bestanden, jQuery 1.9 en 2.0, onderhouden. jQ1.9 zal dan nog support voor IE hebben en jQ2.0 zou precies dezelfde functionaliteiten aan kunnen bieden, alleen dan zonder oldIE support.

Omdat de 2 versies identiek aan elkaar worden heeft jQuery deze code aangeboden om mee te werken:

Code (php)
PHP script in nieuw venster Selecteer het PHP script
1
2
3
4
5
6
<!--[if lt IE 9]>
    <script src="jquery-1.9.0.js"></script>
<![endif]-->
<!--[if gte IE 9]><!-->
    <script src="jquery-2.0.0.js"></script>
<!--<![endif]-->

Hierbij wordt voor oldIE de speciale 1.9 jQuery ingeladen en voor de andere 2.0.

De meeste developers hebben kenbaar gemaakt niet blij te zijn met deze beslissing en ik verwacht dat de populariteit van jQuery hierdoor zal gaan afnemen.

Meer informatie kun je lezen op de Blog van jQuery.

Gerelateerde nieuwsberichten

31/12/2014 Microsoft werkt aan een nieuw browser
04/07/2013 JavaScript altijd aan vanaf Mozilla Firefox 23
22/04/2013 jQuery 2.0 uitgebracht

 

Er zijn 11 reacties op 'Jquery stopt ie support in v20'

PHP hulp
PHP hulp
0 seconden vanaf nu
 

Gesponsorde koppelingen
- Raoul -
- Raoul -
10 jaar geleden
 
0 +1 -0 -1
Bestandsgrootte maakt mij eigenlijk echt vrij weinig uit. Ik denk dat ze beter gewoon twee versies aanbieden, eentje zonder IE maar kleiner en eentje met IE.
Joris van Rijn
Joris van Rijn
10 jaar geleden
 
0 +1 -0 -1
Ik denk dat ze de markt een beetje van IE af willen pushes. Nobel van ze, want op korte termijn zijn ze er zelf de dupe van.
ScrapZz nl
ScrapZz nl
10 jaar geleden
 
0 +1 -1 -1
Waarom gewoon niet ie 8 en lager gewoon niet afstoten
Ik zelf doe dat al een tijdje Te veel werk als je ie ook moet mee laten werken
Wouter J
Wouter J
10 jaar geleden
 
0 +1 -0 -1
IE is helemaal niet slecht. Als je je website goed in elkaar maakt gaat er niks mis...
Ik bouw zelf al zo'n 5 jaar websites en heb nog nooit extra hoeven werken voor IE, ja als ik weer eens de toekomst indook en dingen ging doen die eigenlijk nog niet mogelijk zijn, dan ben je even bezig.
Maar hou je je gewoon aan de standaards dan gaat er echt niks mis, sterker nog. IE is de standaard, als IE iets introduceert wordt het na een tijdje (kan jaren duren) ook in de moderne browsers geïntroduceerd, onder een andere naam, maar het is er wel.
Maar goed, hier heb ik laatst ook al iets over gezegd (hier) en ik ben nu ook bezig met een blogartikel hierover...
IE is niet slecht, IE is juist het beste browser.

Om deze uitspraak kracht bij te zetten, hier een quote van een van de mannen achter W3C, de gene die zichzelf al jaren de standaard noemt:
Henri Sivonen:
createContextualFragment predates innerHTML in Gecko (...) from the era when IEisms were bad but creating own vendor-specific ad hoc APIs was OK

Dit gaat over één van die geweldige dingen van IE die weer eens gekopieerd moesten worden door Mozilla...
Ykcin Ykcin
Ykcin Ykcin
10 jaar geleden
 
0 +1 -0 -1
Ik ben nog steeds niet overtuigd wat het voordeel is om twee verschillende versies van jQuery bij te houden.
Ze zeggen verder zelf ook dat 1.9 eigenlijk alleen bijgehouden word qua bugfixes en dat er niet echt nieuwe functionaliteiten worden toegevoegd aan 1.9.

EDIT: De titel van dit nieuwsbericht is best misleidend, het suggereert dat jQuery stop met het ondersteunen van IE terwijl het eigenlijk alleen om verouderde versies van IE gaat.
Niels K
Niels K
10 jaar geleden
 
0 +1 -0 -1
Quote:
De meeste developers hebben kenbaar gemaakt niet blij te zijn met deze beslissing en ik verwacht dat de populariteit van jQuery hierdoor zal gaan afnemen.


Die snap ik niet? Waarom is dit juist een minpunt?
Jeroen VD
Jeroen VD
10 jaar geleden
 
0 +1 -0 -1
ik denk omdat jQuery altijd gewoon crossbrowser werkte. developers hoefden voor een keertje niet aan IE te denken.... en nu weer wel...
Wouter J
Wouter J
10 jaar geleden
 
0 +1 -0 -1
Niels, jQuery's motto is 'write less, do more' en 1 van hun doelen is om browser verschillen weg te werken, zodat je echt met minder code hetzelfde, of zelf meer, kunt doen.

Wat ze nu doen is zorgen dat die browser verschillen juist weer terug komen. Als je elk browser wilt ondersteunen krijg je minder functies en als je IE niet support krijg je veel meer functies. Dat vind ik belachelijk, ze willen eigenlijk gewoon iedereen verleiden IE niet meer te supporten.

Nu heeft Microsoft een paar dagen geleden wel automatische updates ingevoerd in hun browser, zodat IE6 en 7 gaan verdwijnen, maar IE8 blijft nog steeds bestaan aangezien dat de hoogste versie voor XP is.
Niels K
Niels K
10 jaar geleden
 
0 +1 -0 -1
Quote:
Niels, jQuery's motto is 'write less, do more' en 1 van hun doelen is om browser verschillen weg te werken, zodat je echt met minder code hetzelfde, of zelf meer, kunt doen.

Volgens mij blijft dat gewoon hetzelfde? Alleen je hebt nu twee verschillende soorten files.

Een beetje abstractie kan geen kwaad toch?
Wouter J
Wouter J
10 jaar geleden
 
0 +1 -0 -1
jQuery 1.9 krijgt alleen bug fixes. Stel dat jQuery 2.0 2.1 wordt met perfecte nieuwe API's dan krijgt jQuery 1.9 dat niet...

[offdicussion]
Ik heb momenteel een YepNope wrapper gemaakt om makkelijk dit probleem dat jQuery creëert op te kunnen lossen: https://gist.github.com/3052657
[/offdiscussion]
PHP hulp
PHP hulp
0 seconden vanaf nu
 

Gesponsorde koppelingen
Niels K
Niels K
10 jaar geleden
 
0 +1 -0 -1
Quote:
jQuery 1.9 krijgt alleen bug fixes. Stel dat jQuery 2.0 2.1 wordt met perfecte nieuwe API's dan krijgt jQuery 1.9 dat niet...

Nu snap ik je beredenering :-)

Om te reageren heb je een account nodig en je moet ingelogd zijn.

Labels

PHP nieuws opties

 
 

Om de gebruiksvriendelijkheid van onze website en diensten te optimaliseren maken wij gebruik van cookies. Deze cookies gebruiken wij voor functionaliteiten, analytische gegevens en marketing doeleinden. U vindt meer informatie in onze privacy statement.